Community maintenance is complete. Thank you for your patience!

ONTAP Discussions

LIF has no data-protocol assigned after metrocluster switchover

jenoptik

Hello 🙂

I recently configured a metrocluster. The metrocluster itself is up and running, and the "-MC" SVM is running fine. Also the LIFs assigned to that SVM are there but they don't have the iscsi data-protocol assigned.

 

Anyone seen this issue before?

 

Best regards,

Toni 

1 ACCEPTED SOLUTION

jenoptik

I have to verify it, but maybe I got the solution!

 

I searched for a replication/confirguration resync option and figured out metrocluster vserver resync -cluster lsc-rzs-11 -vserver lsc-rzs-iscsi resynchronizes the vservers configuration. And now there is the data-protocol:iscsi setting as expected.

 

After I verfied switchover I will let you now if it's solved.

View solution in original post

5 REPLIES 5

hmoubara

Hello,

 

Can you run the below command to verify lif replication was successful:

 

cluster::>metrocluster check lif show

 

Thanks

jenoptik

Hi and thank you for the answer. The output of metrocluster check lif is:

 

lsc-rzp-12::> metrocluster check lif show
Cluster Vserver LIF Check Result
------------------- ----------- ----------- ---------------------- ------
lsc-rzp-12 lsc-rzs-iscsi-mc
lsc-rzs-11a_iscsi1
lif-placed-on-dr-node ok
port-selection ok
lsc-rzs-11a_iscsi2
lif-placed-on-dr-node ok
port-selection ok
lsc-rzs-11b_iscsi1
lif-placed-on-dr-node ok
port-selection ok
lsc-rzs-11b_iscsi2
lif-placed-on-dr-node ok
port-selection ok
lsc-rzs-11 lsc-rzs-iscsi
lsc-rzs-11a_iscsi1
lif-placed-on-dr-node ok
port-selection ok
lsc-rzs-11a_iscsi2
lif-placed-on-dr-node ok
port-selection ok
lsc-rzs-11b_iscsi1
lif-placed-on-dr-node ok
port-selection ok
lsc-rzs-11b_iscsi2
lif-placed-on-dr-node ok
port-selection ok

 

and here is the output of net int show -instance of an interface:

 

lsc-rzp-12::> net int show -vserver lsc-rzs-iscsi-mc -lif lsc-rzs-11a_iscsi1 -instance
(network interface show)

Vserver Name: lsc-rzs-iscsi-mc
Logical Interface Name: lsc-rzs-11a_iscsi1
Service Policy: default-data-blocks
Service List: data-core
(DEPRECATED)-Role: data
Data Protocol: none
Network Address: 10.110.111.211
Netmask: 255.255.255.0
Bits in the Netmask: 24
Is VIP LIF: false
Subnet Name: -
Home Node: lsc-rzp-12a
Home Port: a0a-111
Current Node: lsc-rzp-12a
Current Port: a0a-111
Operational Status: up
Extended Status: -
Is Home: true
Administrative Status: up
Failover Policy: disabled
Firewall Policy: data
Auto Revert: false
Fully Qualified DNS Zone Name: none
DNS Query Listen Enable: false
Failover Group Name: Default
FCP WWPN: -
Address family: ipv4
Comment: -
IPspace of LIF: Default
Is Dynamic DNS Update Enabled?: false
Probe-port for Cloud Load Balancer: -
Broadcast Domain: Default
Vserver Type: data

 

Hm.... Why there is no data-protocol: iSCSI? It is on the original cluster.

jenoptik

@hmoubara wrote:

Can you try doing a metrocluster vserver resync

https://docs.netapp.com/ontap-9/topic/com.netapp.doc.dot-cm-cmpr-910/metrocluster__vserver__resync.html

 

 


Thank you. We had the same idea.

So, the problem is solved.

 

Switchover works as expected.

jenoptik

I have to verify it, but maybe I got the solution!

 

I searched for a replication/confirguration resync option and figured out metrocluster vserver resync -cluster lsc-rzs-11 -vserver lsc-rzs-iscsi resynchronizes the vservers configuration. And now there is the data-protocol:iscsi setting as expected.

 

After I verfied switchover I will let you now if it's solved.

View solution in original post

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public