ONTAP Discussions

OnCommand Plugin for Microsoft 4.1.2: API invoke failure: Add Storage System: Make sure HTTPS





We are running SCOM 2012 R2 UR2 and have been using the 4.1.1 version of the SCOM Plugin for Microsoft to connect to 6200 series hardware running 8.2.1 Data ONTAP.



Our new AFF hardware is installed and is running cDOT 9.1.  I am trying to add the new storage system using the OC.Cluseter.OM.Management.Vserver.exe exe in our test environment with version 4.1.2 of the plugin.  When I enter the storage system name, username, and password, I immediately recieve the following error:



API invoke failed






API invoke failed





Make sure HTTPS is enabled on the storage system



I have also tried this wiith the 4.1.1 version of the plugin in our production environment with the same results.




On page 11 of the OnCommand Plug-in for Microsoft 4.1.2 Installation and Setup Guide, it talks about ensure "The required port uses the HTTP or HTTPS protocal."  So why is it suggesting HTTPS may not be enabled?



When troubleshooting, I ran a security ssl show command and saw that Client Enabled was false for the storage system and vserver.



I tried to run a security ssl modify -vserver <storage system> -cleint-enabled true command and received a failure stating "there are no 'client_ca' type certificates for verser '<storage system>'."  I thought it would use the self-signed cert that was created by default, no?



I also saw a previous post relating the API invoke issues pointing to Microsoft KB3175024.  I uninstalled the patch and rebooted per what worked for others. 



Unfortulately, none of the actions have resulted in successful adding of the vserver/storage system.


Any ideas/thoughts?



Much appreciated!!