ONTAP Discussions

Ontap Select 9.2 : NodeCreateFailed InvalidRequestFault.

Hello,

 

I'm trying to deploy a single node Cluster (with evaluation license) ontap select 9.2 on ESX 5.5 (udape 3) with SAN disks (HP 3PAR)

 

The node deployment failed with the following message :

"NodeCreateFailed: Node "chgvavnapt21" create failed: Error during configuration of vnics:  InvalidRequestFault."

 

Could somebody help my to fix this issue

 

Thanks

 

Dom

14 REPLIES 14

Re: Ontap Select 9.2 : NodeCreateFailed InvalidRequestFault.

From IMT Single node 9.2 version is not supported on ESXi 5.5 update 3 for external storage, but for local storage only.

 

Prior to cluster build, recommend you check your portgroup settings and perform a network connectivity start check from the deploy machine to validate connectivity.

Re: Ontap Select 9.2 : NodeCreateFailed InvalidRequestFault.

I'm refering to " Installation and Cluster Deployment Guide Using ONTAP Select Deploy 2.4.1"

 

 

VMFS datastore on external storage array

You can create a VMFS datastore residing on an external storage array. The storage is

accessed using one of several different network protocols. The following figure illustrates

a VMFS datastore on an external storage array accessed using the iSCSI protocol.

Note: ONTAP Select supports all external storage arrays described in the VMware

Storage/SAN Compatibility Guide, including iSCSI, Fibre Channel, and Fibre Channel

over Ethernet.

 

==> My understanding is that Ontap Select 9.2 is supported with ESX using SAN : am I wrong?

Re: Ontap Select 9.2 : NodeCreateFailed InvalidRequestFault.

I did a check connectivity and got this error message :

Error: [500] InternalNetworkNotConfigured: Internal network is not configured for host "chgvasesxt08".

 

I want to deploy a single node cluster, in this case, there is no need of an internal network, but only managment and external

 

Re: Ontap Select 9.2 : NodeCreateFailed InvalidRequestFault.

Apologies, the command is supported only for multi-node cluster to check internal network communication. In your instance, the only perhaps is to check you configuration in ESXi and the command you are using to execute.

Re: Ontap Select 9.2 : NodeCreateFailed InvalidRequestFault.

That really works


@Reg wrote:

Apologies, the command is supported only for multi-node cluster to check internal network communication. In your instance, the only perhaps is to check you configuration in ESXi and the command you are using to execute.


 

Re: Ontap Select 9.2 : NodeCreateFailed InvalidRequestFault.

Hello,

 

I checked my ESXi configuration : every sounds good.

I configured the ESX host and re-run the cluster create in command line (I used the deploy web tool before)
The cluster creation failed with the same error message
"NodeCreateFailed: Node "chgvavnapt11" create failed: Error during configuration of vnics:  InvalidRequestFault."

 

I'm still unable to understand what is wrong

 

Dom

Re: Ontap Select 9.2 : NodeCreateFailed InvalidRequestFault.

Not sure either. Is it a standard or distributed vswitch? Have you registered the nodes using vCentre admin privileges? How many portgroups you have created? Is there any VLAN tagging set on them? Perhaps remove the tagging and check for the external portgroup and check..

Re: Ontap Select 9.2 : NodeCreateFailed InvalidRequestFault.

Another suggestion. Everytime you re-run the cluster create command, start from scratch.. Delete the nodes, and add them in, configure them again via the cli/gui before proceeding to the cluster create.

Re: Ontap Select 9.2 : NodeCreateFailed InvalidRequestFault.

Hi Reg,

 

Unfortunatly, it is exactly what I did each time I rerun the cluster install : I deleted all host and cluster configured or created during the previous test.

 

Regards

 

Dom

Re: Ontap Select 9.2 : NodeCreateFailed InvalidRequestFault.

Is it a standard or distributed vswitch? Have you registered the nodes using vCentre admin privileges? How many portgroups you have created? Is there any VLAN tagging set on them? Perhaps remove the tagging and check for the external portgroup and check..

 

Also, review the /opt/netapp/log/sdotadmin_server.log from the deploy machine to get any clues.

Re: Ontap Select 9.2 : NodeCreateFailed InvalidRequestFault.

Hi Reg,

 

Here some answer to your questions :

 

Is it a standard or distributed vswitch?

==> we are using standard Vswitch on our ESX

 

 

Have you registered the nodes using vCentre admin privileges?

==> I'm using an ESX account with administrator privileges

 

How many portgroups you have created?

==> we count 20 port groups configured on the ESX servers

 

Is there any VLAN tagging set on them?

==> No

 

 

I had a look to /opt/netapp/log/sdotadmin_server.log, but found nothing more

 

------------------------------------------------------------

2017-07-11 13:24:34,859|DEBUG Got data and status code (200)
Got data and status code (200)
2017-07-11 13:24:35,406|DEBUG response body: {"code":51,"details":"Error during configuration of vnics:  InvalidRequestFault","type":"Err"}
response body: {"code":51,"details":"Error during configuration of vnics:  InvalidRequestFault","type":"Err"}
2017-07-11 13:24:35,408|ERROR |client_api_helper.py|183:vm_create| Error: NodeCreateFailed: Node "chgvavnapt21" create failed: Error during configuration of vnics:  InvalidRequestFault.
|client_api_helper.py|183:vm_create| Error: NodeCreateFailed: Node "chgvavnapt21" create failed: Error during configuration of vnics:  InvalidRequestFault.

 

------------------------------------------------------------

 

I also checked the esxadmin.log file, and maybe found somethings, see below

---------------------------------------------------------------

[INFO] [Tue Jul 11 13:22:54 2017] [21870] Validating OVF package contents ...
[INFO] [Tue Jul 11 13:22:59 2017] [21870] Creating VM chgvavnapt21 on chgvasesxt08.
[INFO] [Tue Jul 11 13:23:07 2017] [21870] Uploading system disks to VM chgvavnapt21 ...
[INFO] [Tue Jul 11 13:24:34 2017] [21870] Marked system disks independent-persistent
[INFO] [Tue Jul 11 13:24:34 2017] [21870] Configuring Network ...
[INFO] [Tue Jul 11 13:24:35 2017] [21870] Error encountered while creating VM
[INFO] [Tue Jul 11 13:24:35 2017] [21870] [13] InvalidArg: <scsiC:N> invalid - Invalid/missing disk 'scsi0:0'
[ERROR] [Tue Jul 11 13:24:35 2017] [21870] [51] Err: Error during configuration of vnics:  InvalidRequestFault

-----------------------------------------------------------------

 

I had a look the the cluster node setting on ESX chgvavnapt21 and found one disk attached : "Hard disk 1" on SCSI (0:0)

 

Regards

 

Dominique

 

 

Re: Ontap Select 9.2 : NodeCreateFailed InvalidRequestFault.

Hi Dom,

Documentation screenshot as you showed doesn't specify CDOT image version compatibility. However, when I check IMT as attached, the external storage is only supported on ESXi 6.x.

View solution in original post

Re: Ontap Select 9.2 : NodeCreateFailed InvalidRequestFault.

Hi Reg,

 

Thanks a lot for your help.

 

Best regards

 

Dom

Re: Ontap Select 9.2 : NodeCreateFailed InvalidRequestFault.

No problems.. In my environment I've tried 2 and 4-node implementation on local storage on ESXi 6.0 U3.

Review Banner
All Community Forums
Public