ONTAP Discussions

Perfstat 8.4 hang during gethering data.




I run perfstat8 (GUI, CMD, Linux CLI) at 9.0P2 AFF8080 system. but everytimes perfstat hang during on command "netstat -BMn" , one or two times it (netstat -BMn) passed well but two or three times processing this command (netstat -Bmn)


I tried more than 10 times , but always hang on "netstat -BMn"


sometimes perfstat8 hang during this processing " No Profile domain is provided at commandline hence skipping the command"


Host system OS is windows2008 R2 and Windows2012 server and CentOS Linux 6.


should I try on windows 7 or windows 10?


I can't find the reason. is there somebody have an experiance this? or is there somebody know the reason?


Help~ Me ~~~



Hi savander,

have you tried setting up a preset file to exclude "netstat" commands from collection? Please check KB https://kb.netapp.com/app/answers/answer_view/a_id/1014577/ for how to do that.

Also pay attention that the collection host should be on the same network as the cluster, avoid a lot of network hops or latency between host and cluster.




Hi. thank you for reply.


that URL maybe for internal only.


I can't access that URL with partner level.


Yes. I will try this  --exclude="command=netstat"   today.

But what if Tech center need "netstat" , so I shoud find the main reason. ^^


I will post after running perfstat with exclude "netstat"


Hi savander,

apologies for that I did not check the availability of the KB article.

Sometimes perfstat can fail for various reasons, such as network latency or really high load on the controllers too, so it's important to understand what is causing it for sure.

In case the netstat output is needed by support, you might look into disabling some other unneeded collection for that perfstat; however support will be able to guide you in what to collect if you need to perform a partial collection.