ONTAP Discussions

Pesky SnapVault relationship removal

peter1965

Hello

folks. I need to remove a snapvault relations ship. Key here is that there is no relationship and was a typo when setting up the snapsched. no qtree exists for this relation ship and I wish to remove it

Thi smessage is taken from the log  output of sv-smvi as it would return a error code 21 as it would led me to beleive is due to the fact the line below does not exists as a relation ship but is a pain in the side some place where I need to remove it as mentioned was fat fingered when inititally configuring.

SnapVault relationship found (additional) (primary = uschisan01:/vol/DS_DT_101/, secondary = uschivsan01:/vol/dt_backup_sv/DS_DT_102_q)

Output of snapvault status:

uschivsan01> snapvault status

Snapvault is ON.

Source                      Destination                                State          Lag        Status

uschisan01:/vol/DS_DT_101/  uschivsan01:/vol/dt_backup_sv/DS_DT_101_q  Snapvaulted    37:44:46   Idle

uschisan02:/vol/DS_DT_201/  uschivsan01:/vol/dt_backup_sv/DS_DT_201_q  Snapvaulted    36:15:31   Idle

uschivsan01>

Also from the system manager you can see from attached screen shot that the qtree does not exist -

Is it in the schedule do I need to destroy the schedule and re create it? How do I remove it?

Also when i run the snapvault destination command on each filer it does not show either.

13 REPLIES 13

franja_schmid

- if there is no entry in > snapvault destination

- there are no snapshots in any volume

- and the faulty connection is still showing in > snapvault status

- try on source > snapvault release /vol/<volume>/<qtree> destination:/vol/<snapvault_volume>/<qtree>

- filer output would be>    

/vol/<volume>/<qtree> destination:/vol/<snapvault_volume>/<qtree>  : No release-able destination found that matches those parameters.

Use 'snapvault destinations' to see a list of release-able destinations.

- then check with > snapvault status

it worked for my case...

AndyRawlins

I've spent a whole day fighting with this.  Thanks you - I won't need to be worrying about this all wekend now 🙂

 

 

...though it didn't work on the next broken relationsjip i tried.

RayHoltz

Franja,

I'm not sure how or why it worked, but that removed two stuck snapvault relationship for me also! Thank you!

 

NKAAG

Hi,

Sory for the late answer bu I  had the same issue. To solve it, I deleted all old snapshot and relation ship was removed itself.

DOMINIC_WYSS

I would try to recreate the missing qtree and then do a snapvault stop, so it can delete the destination qtree and remove the snapvault relationship from the registry.

davidrnexon

can you jump into the cli of your destination filer and type qtree show. Does the destination qtree exist ? double check that the qtree does not exist

Then check on your volume uschivsan01:/vol/dt_backup_sv for the snapvault snapshot, if it still exists delete the snapshot and then the relationship should disappear ?

peter1965

Hi – I assume you meant qtree status as the command to type.. None the less it does not appear there. Also no snap exists to delete. Hmm very strange isn’t it.. ? ☺

davidrnexon

what about on the source filer/volume, does the snapvault snapshot exist ?

peter1965

No sir.

davidrnexon

Have you tried the following on the destination:

snapvault abort -h dstfiler:/vol_name/qtree_name ?

pascalduk

Can you try stopping the incorrect snapvault entry on the snapvault destination filer?

snapvault stop /vol/dt_backup_sv/DS_DT_102_q

This should remove any registry information left behind.

ANTHONY_TRAN

Thank you! This worked for me.

peter1965

I tried that – I get the following:

Could not delete qtree: destination qtree does not exist

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public