ONTAP Discussions

Problem assigning replacement disk


We had a faulty disk and recieved a replacement from NetApp.

But when I swapped out the faulty disk and inserted the replacement, the amber warning light conitinued to display.


When I run storage show disk -p


I see all of my disks and their partner but the faulty disk name's partner field is blank.


A message says, "1 disks have downrev firmware that you need to update.


When I tried disk assign all


The error says, "Assign faield because disk 'diskname' has redundancy errors and force option is not specified"


We haven't tried the force option yet.


Can anyone please advise what could be causing this & how we can resolve it? Thanks!




Well, it's possible that new disk is faulty (sounds like one channel does not work); it is possible that original fault was not in disk but in shelf (ESH/IOM/chassis). We do not have enough information and you should contact NetApp support and tell them that disk replacement did not help.

Yes we have already done that. NetApp sent out another replacement disk and the same issue occurs with that one.

So it's not a disk. Must be something on shelf side then.


Are there any commands I can run to help identify any issues with the shelf?

I should add that all other disks in this shelf are functioning normally.




So it turns out we need to upgrade all disk, shelf and atto firmware along with the disk_qual files!


It might be the issue with disk_qual package. Please update it. Use the below command to check the shelf storage show shelf

we had the issue and a -f worked - the error calls for a force option and that's typically -f