ONTAP Discussions

SNMP-problem, routing error?

We have an issue with SNMP and one of our filers. ssh/web access towards the filer is fine, indicating that routing etc. is ok, but this error message keeps pop'ing up in the console:


[snmp.agent.resp.failed:warning]: Could not send response to host : <ip of host> : reason : Failure could be due to either DNS/gateway misconfiguration or takeover/giveback in progress

Timeout, server not responding.


This filer is located off-site, and we access it through a VPN.


The filer is running Netapp Release 7.3.2.


Re: SNMP-problem, routing error?

For some odd reason, it wouldn't send any SNMP-replies through the default gateway. I had to create a static route -> OK.

SNMP-problem, routing error?


can you advise where\how you set the static route and did this resolve the same issue for you?



SNMP-problem, routing error?

I set the static route from the console/SSH-shell, with the route command. See the "Network Management Guide" for instructions.

SNMP-problem, routing error?

Thanks for that MMS, can you elaborate?

were you seeing the same error?  I am getting it on one of my DR filers and snmp, dns and network configs are all fine.

did you just do

route add <ip address> <gateway> then the erorrs stopped appearing on the CLI?

is this issue not the same as netapp bug 344812?

Thanks again


SNMP-problem, routing error?

I don't know about the netapp bug, but the problem (and error messages) disappeared after I added the static route with the route command you are referring to. That's it, not much to elaborate on.

SNMP-problem, routing error?

Great, Thanks a lot smm, I'll give it a try and post the results..


SNMP-problem, routing error?

Dear Sir,

What about the static route which you seting . If you use the default gateway as gateway ?

For example:

fas3240_01> route -s
Routing tables

Destination      Gateway            Flags     Refs     Use  Interface
default      UGS        35  1015295  vif-service

The filer default gateway is  .

Tue Aug  2 17:07:16 CST [fas3240_01: snmp.agent.resp.failed:warning]: Could not send response to host : : reason : Failure could be due to either DNS/gateway misconfiguration or takeover/giveback in progress

we can add the following static route:

route add 1

Is right ?


SNMP-problem, routing error?

Should work, just try it and you'll figure it out.

SNMP-problem, routing error?

Thanks a lot.

Re: SNMP-problem, routing error?

I hit the same problem.  After adding a new gateway I could ping the filer but got the same error noted here.  I don't see adding a static route as a solution. 

I fixed the problem by restarting SNMP:

1) Check SNMP state: "options.snmp"

2) Disable SNMP: "options.snmp.enable off"

3) Enable SNMP: "options.snmp.enable on"

Just like that, SNMP was working as expected without the nasty error message.

Cloud Volumes ONTAP
Review Banner
All Community Forums