ONTAP Discussions

Scheduled Snapshot create failed

edp_citycarburoil

Hi all,

I have a problem with snapshots.

I have a VOLUME (125 GB - 20% snapshot reserve) that contains a LUN (100 GB) for SQL data directly attacched to Windows Server 2008 x64.

Once I started to put data on that LUN, snapshot system told me that "SCHEDULED SNAPSHOT CREATE FAILED" and the most important error is:

"lun_SQL_data - hourly.0 : Snapshot operation failed: No space left on device."

I really don't know what can I do, please give me an advice!

Thankyou very much!

SCHEDULED SNA and I rea

1 ACCEPTED SOLUTION

aliyazici

Hi ,

Try

vol options lun_SQL_data fractional_reserve 5

then take a snapshot.

Regards.

View solution in original post

10 REPLIES 10

aliyazici

Hi ,

Try

vol options lun_SQL_data fractional_reserve 5

then take a snapshot.

Regards.

View solution in original post

I don't know what this string does but it worked

THANK YOU VERY MUCH!

lukasz_borek

Generally (following netapp best practice) :

vol_size = lun size * 2.2

fractional reserve = 100% and turn off snapshot reservation.

Now, when you take first snapshot it will take 100% lun size...you need additional space for overrides.

Have a look at : http://www.netapp.com/us/library/technical-reports/tr-3483.html

But now I don't need to do it anymore, right?

edriel

Hello,

Because you changed your fractional reserve from 100% to 5% there is a chance that you're LUN can go offline. With the change you say to the volume the there will be reserved 5% of the volume for changes (in other words when the LUN is changed for 5% this changes can be saved). However, when you have 6% or chances and you're volume is 100% full and the autogrow of the volume is off then you're volume goes offline.

You need to be carefull when changing your fractional reserve.

Regards,

Eelco

aliyazici

Elco is right,

When you decrease fractional_reserve , there is a chance LUN can go offline.

To prevent this issue, you can set "snap autodelete" and/or "vol autosize"

Example:

snap autodelete lun_SQL_data on

vol autosize lun_SQL_data -m 250g -i 2g on

To choose which one is first:

vol options lun_SQL_data tyr_first snap_delete

or


vol options lun_SQL_data tyr_first volume_grow

Regards.

Mhh I'm not sure if I understand right.

This command should grow the LUN maximum to 250GB by 2GB of each step?

vol autosize lun_SQL_data -m 250g -i 2g on

These commands tell netapp: "When the space reserve is full, TRY to delete or grow (depending on what command I run)" Right?

vol options lun_SQL_data tyr_first snap_delete

or


vol options lun_SQL_data tyr_first volume_grow

Thank you!

Just understood

RTFM!!!

Thank you all!

ps: Do I have to do it also on the other netapp? I think so...

edp_citycarburoil

***********OLD******************When I have to issue the same commands on the other netapp, how can I do that?

I think I have to issue a SNAPMIRROR BREAK and the resize the volume... right?

After that I can do a SNAPMIRROR INITIALIZE correct? ***********OLD******************

Everything ok

I done it by breaking snapmirror, disabling fixed size of volume and then with the previous command I changed the size after that... snapmirror initialize

thank you all guys (once again)

Message was edited by: edp_citycarburoil

upendra

Dear all,

 

Before some days i created 3 TB thik volume and from there i created 2 TB thik lun but from i chose the snap reserve option 0 and then from second day i getting daily below alert message.

 

HA Group Notification from storage  (SCHEDULED SNAPSHOT CREATE FAILED) CRITICAl.

 

please can anyone suggest, do i need to do stop this error...????????????/

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public