Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

ONTAP Discussions

Unable to delete volume

JustinMedcraft

I've inherited a NetApp storage environment and have a volume that just WILL NOT delete.  I am using Clustered OnTAP8.2.3.  I have renamed the volume to 'TO_BE_DELETED'.  There are no baseline snapshots nor are there any other snapshots.  The volume is not associated with any snapshot policy and is not a part of a SnapMirror/XDP relationship.

 

When I take the volume 'offline' and attempt to delete the volume I receive the following message:

 

Error: command failed: Volume "TO_BE_DELETED" in Vserver "svm01" is the source endpoint of one or more SnapMirror relationships. Before you delete the volume, you must
       release the source information of the SnapMirror relationships using "snapmirror release". To display the destinations to be used in the "snapmirror release" commands,
       use the "snapmirror list-destinations -source-vserver svm01 -source-volume TO_BE_DELETED" command.

 

I've even tried to move the volume into a new aggregate and have attempted to take the aggregate offline.  I now know that this is not possible as the aggregate will not delete with a volume contained within it.

 

This is a small volume but I am very keen on getting it removed.  From the error message above I believe that this volume might have originally been a part of a snapmirror relationship.  I look forward to your response.

1 ACCEPTED SOLUTION

hadrian

Hello,

 

I've seen the same thing before - as previously mentioned I used the snapmirror list-destinations and snapmirror release commands and it worked great.   You've also already checked for snapshots which was a good idea.

 

Check out this KB article for more information about using snapmirror release:  Unable to delete a volume as it is the source endpoint of one or more SnapMirror relationships

 

If the KB does not help you, you can also check the error log immediately after attempting to delete the volume:

 

::>  error log show -time >5m

 

If you are still having a challenge with that volume, I recommend to log a support case.   Please post back with what fixed it 😃

 

Good luck!

 

Hadrian 

View solution in original post

4 REPLIES 4

hadrian

Hello,

 

I've seen the same thing before - as previously mentioned I used the snapmirror list-destinations and snapmirror release commands and it worked great.   You've also already checked for snapshots which was a good idea.

 

Check out this KB article for more information about using snapmirror release:  Unable to delete a volume as it is the source endpoint of one or more SnapMirror relationships

 

If the KB does not help you, you can also check the error log immediately after attempting to delete the volume:

 

::>  error log show -time >5m

 

If you are still having a challenge with that volume, I recommend to log a support case.   Please post back with what fixed it 😃

 

Good luck!

 

Hadrian 

View solution in original post

JustinMedcraft

Hi,

 

Thank you for your response.  I also had submitted a ticket to NetApp as I couldn't find a solution on here.  He sent me the same link which ultimately worked.

 

Thanks again.

rwelshman

Do you have OnCommand installed? I wonder if it is part of a dataset somewhere that should be removed as well.

JGPSHNTAP

Did you type snapmirror list-destinations.. If so can you paste it here

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public