ONTAP Discussions

arl from fas8020 to fas8300

tuncay

Hello,

 

I am planning to perform head upgrade from fas8020 to fas8300. but cluster ports in fas8300 are 100GbE but fas8020 are 10GbE.

 

I checked old posts and found the same question and post owner asked to use ha interconnect port which is support 10GbE. (https://community.netapp.com/t5/ONTAP-Discussions/arl-from-a300-to-a400/m-p/159922) My question is same but I am wondering there is no information about this issue. The KB I'm using, is saying fas8020 support upgrade to fas8300 but the is no additional information about this. (For example; fas8020 to fas8300 can temporarily use ha interconnect for cluster connection)

 

Thanks,

10 REPLIES 10

Re: arl from fas8020 to fas8300

TMAC_CTG

been a while since I have done an ARL. Some things to consider

1. Have you upgraded or are you using a "high-speed" (40/100 capable for nodes) switches?

2. If not, have you acquire the appropriate 4x10G cards for your FAS8300s? They do not support breakout from the FAS side.

3.During the process, there is a point where you are able to modify ports for Cluster service. At this point you can chance the ports to reflect what you need

Re: arl from fas8020 to fas8300

TMAC_CTG

This document, starting at page 55

Using Aggregate Relocation to Manually Upgrade Controller Hardware Running ONTAP 9.7 or Earlier (netapp.com)

 

For a little more simplicity, if you can, maybe even upgrade to ONTAP 9.8 (automatic port-placement)

Using Aggregate Relocation to Manually Upgrade Controller Hardware (netapp.com)

Re: arl from fas8020 to fas8300

tuncay

thanks for informations and KB. I also used that kb (9.7) for our plan. 

 

I do not have switches, planing to use ha port for temp which is fas8300 e0a and e0b . After ı completed headupgrade ı will migrate cluster lifs to 100GbE port .

 

 

Re: arl from fas8020 to fas8300

TMAC_CTG

no switches is usually easier. less to deal with.

 

Always cable new unit correctly. e0a/e0b are HA and HA only. 

 

For a temporary purpose...you might be able to use e0e/e0f/e0g/e0h (pick two, like e0e/e0g) ports as 10G for cluster ports.

 

When the migration is done, add the 100G ports to the cluster, let stabilize, then remove the 10G ports and re-use for data as 10G or even 25G ports.

Re: arl from fas8020 to fas8300

tuncay

your suggestion make sense but in my demo environment I had problem about cluster ports.

 

In demo env, I upgraded from fas8020 to fas2552(no internal drive) but one controller completing without problem. After ı select options 6 ( Update flash from backup config), I modify new cluster ports and then migrate cluster lif to new cluster port with no problem. But in second node ı also modied cluster port but when I checked lifs, output just show management lif. I tried to use migrate but it gave error.

After some diggig ı found another solution. before I halt second old node, modfiying cluster port which exists on new node. After then when I attached the cable and boot new node, it is opening with that config and has no problem to connect cluster. 

 

At the end why ı want to use ha interconnect(e0a and e0b) in Fas8300 for cluster port, because it is same cluster port in fas8020(e0a  and e0b). 

Re: arl from fas8020 to fas8300

tuncay

attached both node cluster port modification.

Re: arl from fas8020 to fas8300

TMAC_CTG

I don't think that will work. INTERNALLY, ONTAP treats them differently.

On that platform, you can never use them for anything but HA.

 

Look at the other platforms: they use an internal HA (your FAS8200/FAS80x0) use the backplane for HA. Not configurable

 

Those  HA ports are not configurable. You cannot use them.

 

You either need to get a supported 4x10G NIC for cluster on the FAS8300 or try like I suggested and use 2 of the 4x10/25G onboard ports as a crutch.

 

Re: arl from fas8020 to fas8300

TMAC_CTG

In that case, it looks like the second node has no cluster ports.

I would have create d two new cluster LIFs  on e0e/e0f and be done

Re: arl from fas8020 to fas8300

tuncay

This is very simple but amazing solution. I was stuck to doc, could not think to create cluster lif.

 

thanks for the great answer , ı will try and let you know tomorrow.

 

Re: arl from fas8020 to fas8300

tuncay

Like you said I tried to create cluster lif but it gave an error because it can not communicate to cluster.

I attached the logs.

 

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums
Public