Community maintenance is complete. Thank you for your patience!

ONTAP Discussions

caution after upgrading 8.x metro cluster nodes (7mode) to 8.2.x (options cf.remote_syncmirror.enable)

MARTINBARTH

Hello Community!

I'd like to share the following experience with you.

We've recently upgraded 2 FAS3240 fabric-attached Metrocluster Nodes (HA Pair) running 8.0.2 7mode and as well 2 newly arrived FAS3250 fabric-attached Metrocluster Nodes (running 8.1.x 7mode) to DOT 8.2.1 (7mode).

We've experienced the following issue during the pre-production failover tests of the new system:

Even if the MetroCluster Feature was licensed under 8.1 release correctly, the cf.remote_syncmirror.enable option for this feature to work is not setup correctly by the update procedure. We had to do this manually!

That means, if you lose one complete side of the fabric attached HA Pair, the command cf forcetakeover -d fails with the following message:

cf: forcetakeover -d cannot be performed because remote synchronous mirroring is not enabled

for the MetroCluster Feature to work correctly you have to check the following 2 options:

cf.mode                  ha   
cf.remote_syncmirror.enable
on (same value required in local+partner)

It's easier to check/set this options while both nodes are healthy 🙂

good luck

Martin

1 REPLY 1

simon_wright

Thank you for that we have just come across this during testing before go live.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public