ONTAP Discussions

perfstat error - ssh to filer fails




This is the first time I am using Perfstat. I downloaded latest version (1.07) and ran perfstat7. Put in all required information and clicked Start and then you see a message on the GUI page saying 'checking login information'. After that a windows command prompt opens up and shows the following error -


C:\perfstat>Perfstat v7.39 (4-2013)
SSH to filer <ip_address> fails! Quitting.


I did some research on this and found the page that lists all the flags. The -d flag does verbose output so I generated the command from GUI and then ran it on command prompt and that showed that it failed while running plink.exe. I looked at the plink.exe command that showed in the verbose output and I noticed that it removed the double quotes around the password. So I copied the command and added quotes and then ran it manually and that seemed to work fine. Does anyone know how to work around this or fix this?


I tried the following -

I opened one command prompt and ran the plink command and left it connected to the filer before I ran the perfstat command hoping it would notice there is an open session and just use that but unfortunately that didn't work. it gave me the same error.


Any help would be appreciated. Let me know if you need more info. Thanks.





Refer KB 2011414: Perfstat not working over SSH (SSH to storage system fails). It requires login.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.


@Sahana wrote:



Refer KB 2011414: Perfstat not working over SSH (SSH to storage system fails). It requires login.

Hi Sahana,


Thnaks for replying to my question. I have already looked at this KB article and it didn't help. I can connect to the filer using Putty and plink. I believe the issue is as I have mentioned, the quotes around the password are getting removed. The root users password has a space in it and therefore removing the quotes will cause issues.


I know this is an old thread, but @altlaw's steps helped me to resolve a similar issue.


Using the -d option with my perfstat command for verbose output allowed me to see the plink.exe command, same as @altlaw. I manually ran the plink command from the verbose output, which returned "The first key-exchange algorithm supported by the server is below the configured warning threshold. Connection Abandoned." I had to change my default PuTTY settings for Key exchange by going to Category>Connection>SSH>Kex, moved the target key algorithm above the "- warn below here-", and saved Default Settings under 'Saved Sessions.'


I re-ran the previous perfstat command and still got the "SSH to filer fails! Quitting!" message, but this time found Syslog events on the filer itself relating to permissions issues. I escalated the permissions of the user that I was using in my perfstat command and was able to execute the perfstat successfully. Thanks @altlaw.


I hope this information helps others.