ONTAP Discussions

remove ownership from a broken disk

KireShang

Hi

 

I am trying to decommission a out of support disk shelf. However, there are two failed disks in the disk shelf.

How to remove the ownership from this two faied disks.

 

I have tried run below command, but the system come back the disk is in a different pool

netapp::> disk removeowner -disk 5.1.19

Error: command failed: Failed to remove the owner of disk "5.1.19". Reason: Ownership Remove request failed for disk 5.1.19. Reason:Disk is in broken pool.

 

I also tried run 'disk unfail' without success

 

Can anyone help?

3 REPLIES 3

Re: remove ownership from a broken disk

SpindleNinja

You can't remove ownership from a broken disk, as they say...  "it's dead Jim" 

 

https://docs.netapp.com/ontap-9/index.jsp?topic=%2Fcom.netapp.doc.dot-cm-psmg%2FGUID-84934533-63CA-4A73-82DB-31BBF768C1E8.html

Re: remove ownership from a broken disk

KireShang

if the ownership is not removable, what should I do to stop the ontap alert since these disks are not being used.

Also, can i disconnect the disk shelf without worry about this two failed disk ownsership?

Re: remove ownership from a broken disk

SpindleNinja

If you do "storage disk show" does it list an owner on the failed disks?  Failed disks lose their ownership.  

 

You can just remove the disks before you do anything with the shelf.   As far as the alert,  you should just be able to ack it. 

View solution in original post

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums
Public