ONTAP Discussions

snapvault transfer failure

GUVNIJJAR

We have a snap vault transfer which has failed in the last 2 days, as its lag is now 2 days.   If i look at the snapmirror logs, i see error message relating to this snapvault transfer  :

 

Wed Mar 21 12:43:38 PDT filerA:/vol/log22_28/qlog22_28 filerB:/vol/xvs02_sv/qlog22_28 Request (Update)

dst Wed Mar 21 12:43:39 PDT filerA:/vol/log22_28/qlog22_28 filerB:/vol/xvs02_sv/qlog22_28 Abort (destination requested snapshot that does not exist on the source)

It does an retry but still fails.   Yesterdays snapvault worked fine.

I did a snapvault status -s command on the destination, and i can see a snapshot for the volume, but when i do it for on the source system, i cannot see a snapshot for the source volume.

ANy advise on this issue.

10 REPLIES 10

sudheerns76

I am out of the office until 25/03/2012.

I am not available from 23rd to 25th March due to Public Holiday in

Bangalore and I will be out of station . Please reach out to Steve

Lee/India/IBM, for any Solution queries in my absence. For any management

queries please reach out to Sundar Subramanian1/India/IBM.

For emergency I can be reachable on Mobile Numbers - 9900111441 /

9886395241.

I Apologies for any Inconvenience and Thanks in Advance for your

co-operation.

Note: This is an automated response to your message "[Products &

Solutions] - snapvault transfer failure" sent on 23/3/12 16:09:09.

This is the only notification you will receive while this person is away.

andrewstead

Did you resolve this issue? I have the same problem.

AdvUniMD

Sounds as if snapshot autodelete threw away your baseline snapshot. You should always disable snapshot autodelete on the source volumes forQSM/SnapVault.

I'm afraid there's nothing you can do if the snapshot is indeed lost on the source side. Your only option is to re-start the SnapVault from scratch

do "snap list <volname>" on the source and destination, and try to find a snapshot with the exact same name on both sides.

-Michael

DANTAYLOR80

Hi, is it possible you could provide an example command on what would be required to marry the snapvault back up again?  you mention finding a common snapshot between them just wondered how this would form the command once you have this information?

RANJBASSI

Hi 

 

I am also seeing this error. "Destination requested snapshot that does not exist on the source"

 

I am seeing snaps being created both on the source and destination as per my schedules however I am still seeing the error

 

3 questions I have.

 

  • Does the Schedule name have to be named the same on both source and destination. I have it called SV_Hourly on the source but have given it a different schedule name on the other filer.
  • I have a snapmirror schedule running on this same volume once a week. Could that be causing the snapshot on source to be lost?
  • I havent set a tick on the Preserve old snapshot copies when I created a schedule on the source. Does this need to be ticked?

 

Any advice on this I would appreciate as its doing my nut in!

 

Thanks

 

 

till_echterhof

quick howto setup schedule with snapvault

 

source:

 

snap sched "sourcevol" 0 0 0 <- normaly schedule deactivated

snapvault snap sched "sourcevol" SV_daily 5@22 <- sv schedule same snapshot name on destination required if the snapshot should be transfered

 

destination:

 

vol options "destinationvol" nosnap on

snapvault snap sched -x "destinationvol" SV_daily 31@22 <- "-x" option trigger a transfer from source snapshot

snapvault snap sched "destinationvol" SV_weekly 4@so@22 <- creates a snapshot on destination vol without transfering new data from source

 

RANJBASSI

Many thanks for clarifying that bit of information.

 

So it looks like as I want to transfer the snapshot I need to ensure the names are kept the same on both source and destination.

 

One additional question I have is when I delete the schedule from the destination I noticed when I go to the share path

 

\\filer\volume\~snapshot

 

There are still old snapshots located there. How do I remove all of these so I start with a clean slate and I only see my new schedule/s.

 

thank you

 

till_echterhof

thats just a normal snapshot deleting operation

 

you can use the oncommand system manager or on cli

 

snap delete -a "volname" <- delete all containing snapshots

RANJBASSI

Thank you for your help! Much appreciated. I started off a new SV job with a schedule. Will post back after it has run a few times...

RANJBASSI

Thank you that worked a treat! 

 

I am now on the next stage which is restores of these snapvaults. I created a seperate thread for this so appreciate any advice you can give me. 

 

Thanks

 

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public