ONTAP Discussions

volume move

Gavan4
365 Views

Hi, I have the following problem and I hope someone can help me solve it.

I have an 8 node cluster with a FAS8020, an AFF8040, an AFF-A300 and an AFF-A250.

I want to move volumes from the 8020 and 8040 to the newly added AFF-A250

but when I go to volume move it lets me move them to all other aggregated except the A250.

I guess I have to create a lif for the volume movement...
If yes, how?

If no, what is the reason that I cannt move volumes to A250?

 

Thanks in advance for any tips

1 ACCEPTED SOLUTION

Ontapforrum
265 Views

Could you check if the "SVM/Vserver" from where you intend to vol-move has any resource allocations (aggregates) set ? Following KB has a screenshot to make your task easier. Check if the 'data aggr' for AFF-250 is listed and selected.

 

https://kb.netapp.com/Advice_and_Troubleshooting/Data_Infrastructure_Management/OnCommand_Suite/Aggregate_is_not_visible_on_system_manager_but_can_be_...

 

 

Also, you can try adding the data-aggr-of-AFF-A250 to the VSERVER from where you want to move the vols. This is just an example.
::> vserver add-aggregates -vserver <vserver_from_where_you_want_to_move> -aggregates aggr_data_AFF250_2,aggr_data_AFF250_3

 

Note: For vol-move/snapmirror (with-in the cluster) Ontap uses cluster interconnect so there is no need to create any LIF for this purpose. Though, you will need a LIF to allow end-client to access the volume.

View solution in original post

4 REPLIES 4

TMACMD
362 Views

Whats the output of: 

vserver show -fields aggr-list 

show? 

Gavan4
312 Views

FAS8020::*> vserver show -fields aggr-list
vserver aggr-list
------- ---------
A250 -
Cluster -
DEV_TestSystems -
FAS8020 -
FAS8020-01 -
FAS8020-02 -
FAS8020-03 -
FAS8020-04 -
FAS8020-05 -
FAS8020-06 -
FAS8020-07 -
FAS8020-08 -
ProdSystems -
ProdSystems_A300 -
14 entries were displayed.

Ontapforrum
266 Views

Could you check if the "SVM/Vserver" from where you intend to vol-move has any resource allocations (aggregates) set ? Following KB has a screenshot to make your task easier. Check if the 'data aggr' for AFF-250 is listed and selected.

 

https://kb.netapp.com/Advice_and_Troubleshooting/Data_Infrastructure_Management/OnCommand_Suite/Aggregate_is_not_visible_on_system_manager_but_can_be_...

 

 

Also, you can try adding the data-aggr-of-AFF-A250 to the VSERVER from where you want to move the vols. This is just an example.
::> vserver add-aggregates -vserver <vserver_from_where_you_want_to_move> -aggregates aggr_data_AFF250_2,aggr_data_AFF250_3

 

Note: For vol-move/snapmirror (with-in the cluster) Ontap uses cluster interconnect so there is no need to create any LIF for this purpose. Though, you will need a LIF to allow end-client to access the volume.

Gavan4
199 Views

Hi, thanks for the tip.

I added first
vserver add-aggregates -vserver <vserver_from_where_you_want_to_move> -aggregates aggr_data_AFF250_2,aggr_data_AFF250_3
then tried to start moving a volume, it failed with error "the nodes FAS8020-07
FAS8020-08 " have no LIFs configured for Vserver "vserver_from_where_I_wanted_to_move"

and after creating LIFs for both destination-aggregates and all SVMs it worked.

 

Public