ONTAP Hardware

Lag_inactive on single vif interface


I recently discovered on our fas3270 that one of my physical interfaces for a vif is showing lag_inactive.  Looking at the autosupports it points this as being a port mis-cabled scenario.  We've looked at the switch configs and all looks correct but we cant seem to figure out what were mising.  When i do ifgrp status the lacp input and output packets are incrementing like they should but the port shows suspended on the switch and lag_inactive on the netapp.  This is not a new interface or config on the netapp but the switch side i cannont speak for.


I contacted support and they said to replace the nic card but that is a bigger undertaking than just a quick replace.  So im reaching out to the community to see if you have any ideas on some things to try.


is it possilby to bring down a physical port that is part of a VIF without dropping entire thing?


Also when i unplug the cable from the port on the filer the light continues to stay green.  is this normal for ports that are trunked together?




Can you show the config for the ifgrp? Are the network switches Cisco - and do you have CDP enabled to verify the ports on the netapp are connected to the switch ports as expected?

What does the LACP port channel show on the network switch as the status for the port?


You can try replacing the cables, that would be a quick thing to check.


I would also consider replacing the opticis (SFP), make sure they are the correct optics for a 10G network. You can start at the controller, the network people that I have worked will never believe it's the optic on the network but I have seen it fixed my problem a couple of times (different problem). Have you tried any network stats commands on cDOT to see if there are any errors? If this is a CNA port check the setting, I don't think this would it but worth checking. Have you looked at your log files for any errors?


From NetApp:

Verify the configuration on the switch. The switches needs to be configured so that they are aware of each other and advertise the same MAC. The configuration name is different depending on the Vendor/Model. 

For more information, see examples below:

  • Nexus 7K CISCO VPC (Virtual Port Channel) 
  • CAT 5K CISCO VSS (Virtual Switching System)
  • Juniper EX2200C AEI (Aggergated Ethernet Interfaces)


Hi Stanley,


I work for NetApp doing consulting on system deployment. 


A few commands you should use to troubleshoot this, I infer you are using 7-mode since you mention the ifgrp status command.


1.  CDP command can help totally validate which network switch ports are in use.  Make sure it is on, and then use CDP to show neighbors. 



ps7mode1> options cdpd
cdpd.enable                  on         (value might be overwritten in takeover)
cdpd.holdtime                180        (value might be overwritten in takeover)
cdpd.interval                60         (value might be overwritten in takeover)

ps7mode1> cdpd show-neighbors -v
Remote Device: phx-5k(SSI132908XB)
Local Port:  e0a
Holdtime: 166
Capabilities:  Switch, IGMP
Platform: N5K-C5010P-BF
Remote Port: Ethernet120/1/25


2.  Ifstat command is what you want to use to understand individual Ethernet port usage and frame counts.  Use ifstat against the two members of your ifgrp and see if one has more traffic than another.  If you like you can clear the existing counters with "ifstat -z", just make sure to record the pre-cleared statistics prior to doing so. 



I do find it odd that the link light stayed on when you pulled the cable, and I suspect that'd be the only reason Support went down the road of trying to swap the specific physical interface.  I like the idea of checking the SFP as well.  


In my travels, lag_inactive *always* ended up as a mis-configuration or mis-communication as to which ports are involved in the LAG.  If the port is suspended on your network side, confirm the cabled port with CDPD and then have them unsuspend it (up-up it), and see if the port-channel goes live on all member ports.












Refer KB 3013774

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.