ONTAP Hardware

Network Mismatch Help



Last week i did an update to OnTap 8.1.4p3 7-Mode on one of our v-series devices (V3240) and after the reboot it it decided that one of the 2 physical network interfaces would change from a speed of 1Gbps to 100Mbs. This caused a mismatch because it was in an interface group and the interface group decided it was going to go offline.

Essentially the interface group (vif0) should contain e0a and e0b. At the moment it only has e0b in due to this mismatch. If you look at the ifconfig output you can see that e0a is reporting a speed of 100Mbs. The network guys are telling me the network switch ports are reporting a speed of 1Gbps, Full Duplex and look fine. I had them shut down the ports and that made no difference, i disabled/enabled the port on the NetApp and now running out of ideas.

I am working with our network team on this but wonder if anyone has come across this before and/or has any possible ideas for me to try as i am stuck at this moment. I have detailed the output of /etc/rc, /etc/hosts and an ifconfigoutput if that helps?

Output of /etc/rc

#Auto-generated by cifs setup Fri Aug 24 12:07:19 BST 2012

#Auto-generated by setup Sat Aug 11 17:34:54 GMT 2007

hostname NETAPP01

ifgrp create lacp vif0 e0a e0b

vlan create vif0 60 70

ifconfig vif0-60 `hostname`-vif0-60 netmask partner vif0-60

ifconfig vif0-70 `hostname`-vif0-70  netmask partner vif0-70

route add default 10.x.x.x 1

route add net 10.x.x/24 10.x.x.x 1

routed on

options dns.enable on

options nis.enable off


timezone GB

Output of /etc/hosts

#Auto-generated by setup Sat Aug 11 18:20:27 GMT 2007 localhost localhost-stack

127.x.x.x localhost-10 localhost-bsd

127.x.x.x localhost-20 localhost-sk

10.x.x.x   NETAPP01 NETAPP01-vif0-60

10.x.x.x        NETAPP01-70 NETAPP01-vif0-70

#       NETAPP01-e0M

#       NETAPP01-e0P

Output of ifconfig -a

e0a: flags=0x2f0c866<BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        ether 00:a0:98:1d:55:b6 (auto-100tx-fd-up) flowcontrol full

  e0b: flags=0x8af0c867<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 1500

        ether 02:a0:98:1d:55:b6 (auto-1000t-fd-up) flowcontrol full

        trunked vif0

  vif0: flags=0xa2f0c863<BROADCAST,RUNNING,MULTICAST,TCPCKSUM,VLAN> mtu 1500

        ether 02:a0:98:1d:55:b6 (Enabled interface groups)

  vif0-60: flags=0x2b4c863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        inet 10.x.60.x netmask 0xffffff00 broadcast 10.x.60.x

        partner vif0-60 (not in use)

        ether 02:a0:98:1d:55:b6 (Enabled interface groups)

  vif0-70: flags=0x2b4c863<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500

        inet 10.x.70.x netmask 0xffffff00 broadcast 10.x.70.x

        partner vif0-70 (not in use)

        ether 02:a0:98:1d:55:b6 (Enabled interface groups)



Andy -

Experience has taught me that when 'auto' doesn't work correctly, there's an underlying problem with the link.

Have you checked the physical cabling ?

Tried a different port on the switch ?

I was setting up a NetApp classroom lab for the US Army on site at Fort Gordon, Georgia years ago.

It's home to the US Army Signal Corps, and their IT Training school.

I had a brand new FAS2040 and a Cisco 2900 switch.

I couldn't get 1g working for the life of me.

Tried hard configuring the link speed, bouncing both devices, with no luck.

Then I remembered what I'd taught for years - check the cable.

After pulling the cable off the floor I found a pretzel twist in the middle of it.

I asked a soldier if they had a new Cat-5 cable.

He ran down the hall and grabbed a fresh cable out of the closet, complete with the mil spec inspection sticker on the bag.

Plugged the new cable in, bounced the interface, and viola ! 1Gb up and working.

I hope this response has been helpful to you.

At your service,

Eugene E. Kashpureff, Sr.

Independent NetApp Consultant, K&H Research http://www.linkedin.com/in/eugenekashpureff

Senior NetApp Instructor, IT Learning Solutions http://sg.itls.asia/netapp

(P.S. I appreciate points for helpful or correct answers.)


Hi Eugene,

To be honest checking the cable was my next move. I was working on the basis that the link was up and working as expected and the cable has not been touched in the slightest. But i will be going to ask if a temporary cable can be put in just to test it for sure and see what happens. Wasn't sure if there could be some 'funky' netapp stuff going on here could look at as well .

We shall see.