ONTAP Hardware

Replace faulty/broken disk in NetApp



We have NetAppModel V3140 and OnTap version mode.

Recently we had failed/broken disk so I have replaced the broken disk with new disk. Existing disk was 15K and 450GB however, I replaced the new one with 15K with 600GB. We don't ahve support maaintenance with NeApp so I bought disk from one of our vendor.

I am new to NetApp so don't know excet proces to replace faulty/broken disk. All I did is removed faulty diska nd inserted new one. If I am not wrong the new disk shoud be configured as spare one however, Now OnCommand disk status for new disk is still showing Broken. If I run the command aggr status -f it's not reporing any broken disks.

Please find attached screen shot for the disk status, disk ID ( 3d.13.10) this is the new disk I replaced with faulty disk. It' stus is showing as broken and also firmware version is different than the existing disk. I thought when you replace the disk it should automatically configured as spare one but it's not. Could you please advsie why new disk status is showing as broken and not spare?





can you run a "disk show -n" on the filer? the disk may need to be assigned first.


yes, I did ran the command disk show -n and it shown no disk match option -n


Yes, I ran the command disk show -n, it sayd no disks match option -n

As this new disk is not from NetAPP it's firmware is also on different version than teh existing disks, so that could be teh issue it's not configuring as spare? please check attached screen shot for the firmware version on the new disk as wella s existing disks. new disk id is 3d.13.10



 You can't use third-party disk, it is not supported. Disk should be from NetApp with NetApp firmware.


can you provide the sysconfig information for that disk?

as noted, if the disk doesn't have a netapp label, it won't be recognized or used in the filer.




I have logged onto one controller SSH and ran below commnand, attahed is the output. FYI, we ahve two controller configured in HA. Please check attached file forsysconfig -r outlput.



Can you give the output of a sysconfig -a -> just the disk information on adapter 3d would be good. This will list the type of disk.


I did SSH to controller1 and controller 2, ran commands sysconfig -a and sysconfig -d on both controllers, please find attached file for output.I will post them into another reply as I can't attach more than one file here at a time



attaching syconfig -a on controller 1


attaching sysconfig -d on controller 1


attaching sysconfig -d on controller 2


Ok, well it definitely doesn't recognize the disk. Either try to reseat the disk - take it out, wait 30 seconds or so, and replace it. But if the disk isn't a refrusbished or new NetApp disk it won't accept it and could cause issues. It has to have a NetApp part number on the label somewhere to be compatible.


I already re-inserted the disk yesterday and also had error "[DC2NC001:disk.init.badSectorSize:error]: Disk 3d.13.10 has an unexpected sector size (512 bytes) and cannot be used."

Sysconfig -a shows below output


 17.14: NETAPP X999_S15K7__4160 000B 56.3GB 512B/sect (Failed)


I just copied one line from the sysconfig -a output and have pasted above just fyi. If it's showing the disk as above that means it's recognized, isn't it? I toghut if it's showing the disk info under sysconfg -a that means disk is recognized.


The replacement disk is in shelf 17, bay 14

As per the sysconfig -a, it shows disk lablled as NETAPP, however, it shows 512/sect size, and existing disks are 520/sect size, would that be issue?

the new disk is not from Netapp just bought it from our vendor, it's size is 600GB and all existsing disks size is 450GB.




Hi Nutan,

Disks attached to the NetApp storage controllers cannot be used by Data ONTAP unless it meets certain requirements. The firmware level is one of them and is very important. NetApp hardware such as SAS HBAs, intelligent cables, ACP processor, Shelf IO modules etc, need to communicate with the disk to determine the status of disk. At some point, Data ONTAP need to have read and write access to the firmware itself, in order to do certain adminstrative tasks. For example, if a disk fails for some reason, like the number of bad sectors excceding the allowed thresholds, the information regarding the failure will be written to both Data ONTAP Failed Disk Registry (FDR) as well as the "failure bytes" inside the firmware. Also, while booting or detecting the attached disks, Data ONTAP needs to read the firmware to make sure that the "failure bytes" are clean. Otherwise the disk will be considered as failed and will not be used as even a spare disk. Further, each controller and disk shelf can support only limited types of disks. Physical sizes and shapes, capacity, protocol used etc does not necessarily guarantee that the disk is usable on a NetApp controller. You can get a list of supported controllers, disks, shelves and firmware versions for each version of Data ONTAP from the hardware universe at https://hwu.netapp.com.

In short, this disk cannot be used on a NetApp storage controller. You may probably connect that to a server's local HBA and buy a supported disk from NetApp.


Hope that helps.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Cannot find the answer you need? No need to open a support case - just CHAT and we’ll handle it for you.


Thanks for your reply!

Yes, firmware level on this disk is different than the existing disk and I think that could be the reason it's still showing as BROKEN in the OnCommand console. We don't have supprt with NetApp to purchase the disk from them. So I need to purchase it and replace it.  I am new to NetApp so don't know excat process to replace the faulty disk. All I did is bought new disk from the vendor with same speed howeevr, size is bigger than the existing disk. Could you please tell me what is the exact procedure to replace faulty disk? We had two failed disk and I just bought one new disk and have repalced it and I haven't purchased the second disk yet.

All I did is, removed faulty first disk, inserted new disk, confirmed disk auto assign option is on, so assumed that it should be automaitcally assigned to the controller, othertahn this I didn't run any other command, so please advise if I am missing anything here.


so please advsie:

how to update formware on one disk in neatpp?

exact process to replace the faulty disk in netapp? the new disk is not from NetApp so please advsie the procedure accordingly.





You have to purchase a NetApp disk - either from NetApp directly or through a third-party. No other type of disk will work in the filer. If you don't have support, you will have to pay the full price.


Hello, I've a broken drive 300 GB 15K and need to know if I can use a 600 Gb 15K. This Cluster already have 600 GB 15 K in other shelfs and the drive I will use is a NetApp original spare drive. Can I use it for the replaceemnt?





Yes, you can, but disk will be down-sized to 300GB, you will not be able to use full capacity as long as disk remains in raid group with 300GB disks.