ONTAP Rest API Discussions

API version 1.21

linli

We have backup client using snapdiff backup for NetApp volumes, the backup software recommends ONTAP API 1.21 and above, the current API from NetApp storage is 1.17, by the way the storage have ONTAP 9.7P15. How can we upgrade API from 1.17 to 1.21? Do we have to upgrade ONTAP 9.7P15 to a newer version to get the newer version of API?

4 REPLIES 4

linli

I'd like ask the question in a different way. Does any one know which ONTAP 9.xPy has REST API 1.21 or newer? Thanks,

andris

I hate to say this, but those "ONTAP API" version numbers don't ring a bell (at least for me).
ONTAP REST API versioning is based on the ONTAP version, itself (9.6, 9.7, 9.8, etc.)

Can you provide more details about "ONTAP API 1.21 and above, the current API from NetApp storage is 1.17" that was referenced by your backup software (vendor?)

linli

Yes, the vendor is IBM Spectrum Protect backup and archive Linux client software 8.1.13. we got trace file for them to review for a backup error. The ONTAPI is 1.17 with ONTAP 9.7P15, IBM support said we should have ONTAPI 1.21 or newer.

 

"

The Filer <netapp-home05-systems02> is at ONTAP version <9.7.0> and ONTAPI version <1.170>.SNAPDIFF File Access Protocol: <TRUE>.

 

The trace seems that this filer has the ontapi version 1.17 while the snapdiff feature requires at least 1.21.

Could you check your filer ontapi version and if you can upgrade to 1.21 or later?

 

 

"

 

That's the reason that we are trying to know which ONTAP version has ONTAPI 1.21 or newer.

andris

In case it is helpful, check out:

Public