ONTAP Rest API Discussions

QoS Policy Cluster Scoped

abhijeetjanwalkar
999 Views

I am trying to create new policies in OnTap 9.11 and it to cluster.

Error I m getting "error_message": "Field "scope" cannot be set in this operation", "msg": "Error when calling '/storage/qos/policies': {'target': 'scope'}", based on https://library.netapp.com/ecmdocs/ECMLP2882307/html/#/storage/qos_policy_create "scope": "cluster" is a valid option.

I am using ansible Module ' netapp.ontap.na_ontap_restit:' and body looks like this

body:

  name: abhiClusterFixedQosTest

  fixed:

    max_throughput_iops: 0

   capacity_shared: true

   max_throughput_mbps: 0

   min_throughput_iops: 0

   min_throughput_mbps: 0

svm: name: "abhitest001"

scope: 'svm' # or scope: 'cluster'

but neither works Code works if i am not using scope as an option but then the policy is created for SVM,

more details here 'https://discord.com/channels/855068651522490400/1082967001770774538/1082967001770774538

this is error code 262196 Field cannot be set in this operation.

This was added in 9.11 Scope (9.11) string Scope of the entity. Set to "cluster" for cluster owned objects and to "svm" for SVM owned objects.

Enum: [ cluster, svm ]

 

Scope option is not present in the command level as well.

I also tested this on ontap 9.12 with same results.

 

Thanks for any inputs.

Abhi

1 ACCEPTED SOLUTION

Twesha
857 Views

Hi Abhi,

 

This looks like a bug either in the endpoint implementation or the documentation. I took a deeper look at the API spec and it looks like the scope field is marked as readOnly which is why you are not able to set it in the POST request. 

View solution in original post

1 REPLY 1

Twesha
858 Views

Hi Abhi,

 

This looks like a bug either in the endpoint implementation or the documentation. I took a deeper look at the API spec and it looks like the scope field is marked as readOnly which is why you are not able to set it in the POST request. 

Public