The community will be undergoing maintenance soon, requiring Read-Only mode. Click to learn more.

Simulator Discussions

9.1 and 9.2 simulator hangs at boot loader in virtualbox

pvdputte

Hi,

 

I can get the 9.0 sim to boot fine in VirtualBox 5.1.x, but when trying 9.1 or 9.2 the boot process halts almost immediately:

 

BTX loader 1.00  BTX version is 1.02

Consoles: internal video/keyboard

BIOS drive A: is disk0

BIOS drive C: is disk1

BIOS drive 😧 is disk2

BIOS drive E: is disk3

BIOS drive :F is disk4

BIOS 639kB/3668920kB available memory

 

FreeBSD/x86 bootstrap loader, Revision 1.1

(root@bldrh6svl67.eng.netapp.com, Mon Jun 19 15:28:57 PDT 2017)

Loading /boot/defaults/loader.conf

|

 

That's it. It probably starts loading some binary which subsequently hangs.

 

Is anyone running 9.1 or 9.2 in VirtualBox without issues? 9.0 works rather well but seems to have intermittent network connectivity issues.

2 REPLIES 2

SeanHatfield

Add a serial port to the VM, and in the vloader:

setenv console vidconsole,comconsole

 

Edit: Screenshot:

vbox-91.png

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

pvdputte

Fantastic. Just adding the serial port was sufficient. Using VirtualBox 5.1.28 on Ubuntu by the way. Thanks!

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public