Simulator Discussions

ESXi 6.5 Simulator 9 and 9.1 import/compatibility issues


I have experienced numerous issues when trying to import or run the version 9 & 9.1 simulators on ESXi 6 or 6.5


The ova import fails with multiple/various errors or never completes. (Compressed Disk images + others)


I've tried both IE and Firefox browsers etc. - I'm using Windows 10 Ent LTSB


I've tried importing the simulator into Workstation12 then exporting and re-importing intos ESXi - No go.


I've used the VMware vCenter Standalone converter to "Push" a VM up to the ESXi - but then it fails at boot saying it can't read the environment.



I tried using the OVFTool to convert the ova to vmx - then uploaded the VM and registered it - Still having issues on boot, Network adapters won't keep settings or see existing portgroups etc.


So many issues - surely someone at NetApp is aware of this?!



Does anyone have a workaround/fix?




Re: ESXi 6.5 Simulator 9 and 9.1 import/compatibility issues


I've have had very little success in general uploading OVA templates using the ESXi host client.  On 6.0 you can still use the C# client.  Uploading via vCenter also works.  I haven't tried it on 6.5 yet.


Uploading via the OVFTool command line utility does work.  The issue you have when you do a push is it tends to create it with a newer vmx version (virtual hardware version) which makes the boot loader environment innaccessible.  You can work around this by adding a floppy drive to the VM and attaching a blank floppy image.



If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: ESXi 6.5 Simulator 9 and 9.1 import/compatibility issues


Thanks for the tip about the vmx version - I didn't need the to add the floppy because, the vCenter Standalone Converter has an option for Hardware Compatibilty "Virtual Machine Version - dropdown" before you push it up. - I had been choosing the newest version before.


NOTES - For anyone needing help with this issue (Also see attached images):


I opened the ova in VMware Workstation v.12 -Saw that it defaulted to a version 6.5-7x virtual machine when I chose manage -> change hardware compatibility - see image



Then I used Stand Alone Coverter - chose Convert Machine option - and navigated to the Workstation's VM folder (You need the vmx which is why I opened it in Workstation) - to push it up to my ESXi 6.5 host.



Before I pushed it, I made sure to select version 7 from the Virtual Machine Version dropdown.




The Simulator image comes with 4 Drives attached and they're all THICK provisioned.

One of those drives is 230GB - So you might have to set it to thin provisioned based on your environment - because your host storage may not have room for all 230GB to be thick provisioned.

Again - The standalone converter gives you the option to edit the VM's parameters before pushing it up so you can switch.



Re: ESXi 6.5 Simulator 9 and 9.1 import/compatibility issues




Sean was right about the VM Hardware Compatibility issue but, I didn't need the "Virtual Floppy" because, the vCenter Standalone Converter has a Hardware Version/Compatibility drop down option before you push.


I opened the OVA in Workstation - then pointed the standalone converter at the vmx file.


I chose version 7 (Workstation showed it as 6.5-7x compatible once opened) before I pushed the VM up to my ESXi 6.5 host.



The simulator comes with 4 Drives attached - DEFAULT TO THICK PROVISIONED IN STANDALONE CONVERTER - one of which is 230GB - so you may have to change to thin provisioned.


Again the standalone converter gives you this option.



View solution in original post

Re: ESXi 6.5 Simulator 9 and 9.1 import/compatibility issues


I can confirm that there are major issues/limitations with the new ESXi "Host Client." - Host Client is the ESXi Web Client.



ESXi 6.5 - Is "Host Client Only" Basically, the ESXi Host Client is missing key features/capabilities that are present in the thick client.


Namely, there are known issues with importing and exporting ova's/ovf's etc.



However ESXi 6.0 Still Supports the thick client - I recommend you consider that for building a lab or whatnot.


Uploading the simulator OVA with the thick client on ESXi 6.0 update 2 went smoothly.



NOTE: You can install an ESXi 6.0 VM or box to get the 6.0 thick client. - The 6.0 Thick Client will also connect to ESXi 6.5 - But it doesn't come with it - So Workaround



However, whether or not the simulators are fully functional remains to be seen and it should be noted that either method discussed in the thread seems to work equally well.

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums