Simulator Discussions

Experiences with OS X Fusion 8.0 with NetApp sim 8.3?


Just wondering if anyone has any good or bad experiences running 8.3 vsim under the new Fusion 8.0. I'm about to try it out and thought I'd ask.



Since my original post I went ahead and upgraded my environment to Fusion 8.0 and installed a couple of 83 vsims (GA, not RC1)


However, not being sure how 8.3 vsim would react, I DID NOT upgrade the 'Virtual Machine hardware version' when prompted to do so ... and everything seemed to work fine. I was running Fusion 6.x previously. To be honest, I'm not 100% certain what VM-HW version that was providing.


Those two 83 vsim I built report their VM-HW at version 7. All is well.


As a test, I had a 3rd 83rc1 vsim which I shutdown and used Fusion Setting Compatibility to upgrade to current which turns out to be VM-HW version 12. That vsim will no longer boot but instead gives the error shown below. Questions:


 Q: Does anyone know if this can be fixed or should I burn it and start over?

 Q: Does anyone know if upgrading an 83 vsim to Fusion 8.0's VM-HW version (12) at the start of a vsim install process would work better?





PS/FWIW -- I took a chnace and upgraded a Window 2008R2 server to the latest and saw no problems.



I've been holding off on upgrading mine.  Thanks for posting back.


SO from what I see there, the loader can't find the kernel or the env file.  This makes me think the drive ordering has changed.


From the loader can you run "lsdev" and post the output?


It should resemble this:

VLOADER> lsdev
cd devices:
disk devices:
    disk0:   BIOS drive A:
    disk1:   BIOS drive C:
      disk1s2: FAT-16
    disk2:   BIOS drive D:
      disk2s1: FFS  bad disklabel
      disk2s2: FFS  bad disklabel
    disk3:   BIOS drive E:
      disk3s1: FFS  bad disklabel
      disk3s2: FFS  bad disklabel
    disk4:   BIOS drive F:
pxe devices:


The kernel, ontap image, and the env file are on the fat16 volume on disk1s2.  If that volume appears to be on a different disk number, it won't be able to find it at boot.




I'm no expoert on stuff at this lvel but I think you're right. Here is my lsdev from that vsim (different from yours). I wonder if this is salvagable or I should just burn it 🙂


lab-stor lsdev.png 


I think we can fix it.


Since drive A is missing, see if the VM has a floppy drive.  If not, add one and try it again.

If it still doesn't work, point the floppy drive to a blank floppy image.


If that still doesn't work, we can change the pointers so it looks for disk0, but one of them is hard to get to.






I have 8.3 running with Fusion 8.  The missing floppy is the cause for the boot failure.


I created a floppy.img file with dd as follows:


dd if=/dev/zero bs=1024 count=1440 > floppy.img


I then used disk utility to open the floppy.img file and erase/format for MS-DOS


Next, add a floppy device for the 8.3 VM and point it at the floppy.img file


Last step was to specify the first IDE disk as the startup disk with Fusion settings. This DID NOT work until the floppy device was added.


Start it up and all is good.


BTW ... both of my machines are upgraded to version 12



Perfect !!! That works. Thanks John.


For my edumication ... what is/was going on there? 


Can/should  I keep this floppy image around and can I the same image for a couple other 83 VMs to correct the issue when I upgrade them? It sounds like you're saying what this does is to let me pick the 1st IDE drive as the startup disk ... is the floppy image really needed after that?


Thanks again. 



i had the same issue with my sims running under fusion 8.

i did upgrade the vm when intially prompted. 


all i did to get around it, since the floppy drive is required, is just use makefile in terminal and created a 1KB file named "dummy_floppy_drive.flp"

the flp extension is required for fusion to know it is a floppy drive.

i only have the one flp file and all my sims point to it. from my experience, it is needed on boot.

haven't had a problem with the sims after that