Simulator Discussions


Initialize-NaSecureAdminSsh in 8.1 vsim?


I'm running 8.1RC2X13 7-mode, and Data ONTAP PowerShell Toolkit version

I am trying to execute Initialize-NaSecureAdminSsh with key options, and I get an error, "Cannot determine connection type", followed by mention of an ArgumentException.  To make sure it isn't a problem with PowerShell connectivity, I executed Get-NaTime and that ran successfully.  Full details below.  Is this PowerShell cmdlet supported in this build (or a later build)?  Is there something wrong with the arguments I'm passing?

Thanks in advance,


(From Windows PowerShell ISE, after loading OnTap modules)

PS C:\> Connect-NaController -Credential $cred

Name                 Address           Ontapi   Version

----                 -------           ------   -------    1.15     NetApp Release 8.1RC2X13 7-Mode: Thu ...


PS C:\> Initialize-NaSecureAdminSsh -Ssh1HostKeySize 768 -Ssh1ServerKeySize 512 -Ssh2HostKeySize 768 -Force

Initialize-NaSecureAdminSsh : Cannot determine connection type

At line:1 char:28

+ Initialize-NaSecureAdminSsh <<<< -Ssh1HostKeySize 768 -Ssh1ServerKeySize 512 -Ssh2Hos

tKeySize 768 -Force

    + CategoryInfo          : InvalidOperation: ( [Initiali

   ze-NaSecureAdminSsh], ArgumentException

    + FullyQualifiedErrorId : ApiException,DataONTAP.PowerShell.SDK.Cmdlets.Secureadmin



PS C:\> Get-NaTime

LocalTimeDT                   UtcTimeDT

-----------                   ---------

5/18/2012 8:59:52 AM          5/18/2012 12:59:52 PM


PS C:\> Get-NaToolkitVersion

Major  Minor  Build  Revision

-----  -----  -----  --------

1      6      0      132



Re: Initialize-NaSecureAdminSsh in 8.1 vsim?

This is a known issue that will occur when multistore is licensed and the option "licensed_feature.multistore.enable" is "off".  You can either set that option to "on" then use Connect-NaController to reconnect to the simulator, or get the latest version of the toolkit (version 2.0) which fixes the issue:



Re: Initialize-NaSecureAdminSsh in 8.1 vsim?

Thanks for the help, Steven.  After changing the option, I tried initializing SSH via:

Initialize-NaSecureAdminSsh -Ssh1HostKeySize 512 -Ssh1ServerKeySize 768 -Ssh2HostKeySize 1024 -Force

and it didn't seem to work.  Is there a log I can look at to review?  Do I need to reboot the vSim for the change to take effect?

Thanks again,



Re: Initialize-NaSecureAdminSsh in 8.1 vsim?

Are you experiencing the same issue after changing the option?  If you are experiencing the same issue, it may work if you restart your PowerShell session.

You can verify SSH is working by using the Invoke-NaSsh cmdlet (something like "Invoke-NaSsh hostname").  You can also try running Initialize-NaSecureAdminSsh with the -Verbose switch (Initialize-NaSecureAdminSsh -Ssh1HostKeySize 512 -Ssh1ServerKeySize 768 -Ssh2HostKeySize 1024 -Force -Verbose).  There may be a message in the Verbose output that will point to what the issue is.


Check out the KB!
Knowledge Base
All Community Forums