Simulator Discussions

Issue with CIFS Simulator 8.0.1 c-mode


Anyone have issues with the c-mode 8.0.1 Simulator and CIFS.

I was able to attach to the domain and configure the share, but unable to access the cifs share.



It is usually something simple and will be in the steps in this KB... go through all these and make sure you have time within 5 minutes of the DC, the default pcuser unix user (unix user and group create), then have a default unix user for cifs or the shares won't work "vserver cifs options modify -vserver -default-unix-user pcuser" ... not having the default unix user (even if cifs only) is the most common reason it doesn't work.  Work through this KB step-by-step and I bet it works for you.  Not all the steps are needed (nis, usermapping, export policy, etc) when cifs only, but you must have the unix user and the mapping.

Data ONTAP 8: How to create a CIFS server in Cluster-Mode


Hi, I've got the same problem.

Everything seems fine but when I go to browse the share I'm getting denied access. Have checked all the user mapping validations through the sim console, that all looks good. Permissions look ok, so I'm a bit stumped.

Any one had any luck getting CIFS up and running?


Look at the security style of the root volume of the share.  I have seen this on installs and the volumes get built with a security style of UNIX by default.  Try setting it to NTFS if you can as that has fixed this issue for us.  Haven't tried MIXED mode but that may work also. 


Thanks ljuhnke, that's fixed it. Had the root volume set to UNIX style permissions. Have change to NTFS and all working now, thanks again!