Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Simulator Discussions

Network issues on 7.3.6 Simulator


I have the simulator running via VMWare Workstation Player 12 with no issues.

However, we need to decommission the server it is running on, so we thought we would run it on a VM running Linux.

Downloaded the iso, and installed fine.

Simulator boots up, and immediately floods the screen with - pf_packet_write: write packet: No such device


The interface is showing as up. The underlying eth0 on Linux is UP, and in promiscuous mode: -


inet xx.xx.x.151 netmask broadcast xx.xx.x.255
inet6 fe80::21d:d8ff:feb7:1cc3 prefixlen 64 scopeid 0x20<link>
ether 00:1d:d8:b7:1c:c3 txqueuelen 1000 (Ethernet)
RX packets 68191 bytes 11582947 (11.0 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 26144 bytes 7666125 (7.3 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


On the simulator: -


ns0: flags=0x2c48867<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet xx.xx.xx.201 netmask-or-prefix 0xffffff00 broadcast xx.xx.xx.255
ether 00:50:56:1c:2b:e6 (auto-100tx-fd-up)
ns1: flags=0x2408866<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet xx.xx.xx.203 netmask-or-prefix 0xffffff00 broadcast xx.xx.xx.255
ether 00:50:56:1d:2b:e6 (auto-100tx-fd-cfg_down)
lo: flags=0x1948049<UP,LOOPBACK,RUNNING,MULTICAST,TCPCKSUM> mtu 9188
inet netmask-or-prefix 0xff000000 broadcast


The 2 IP's for ns0, and ns1 are in DNS.

I can ping the IP's from the simulator fine, but nothing else, and as soon as I do, I get pf_packet_write: write packet: No such device


I cannot ping these IP's from any external server.


This is the defaults on the Linux host: -


echo Loading defaults. Run with -i option to ignore defaults


I downed the ns1 on the simulator, and got the following: -


ifconfig ns1 up(promiscuous mode not enabled on eth0:)pf_packet_init: can't set IF flags: Cannot assign requested address


eth0 is promiscuous, and I have hardcoded it in /etc/rc.local


ifconfig eth0 up
ifconfig eth0 promisc


/etc/resolv.conf setup on the filer, pointing to the domain controllers.



Any ideas on what to check/change would be greatly appreciated.


Many Thanks.



I have changed this now.


I have created a 2nd interface on the lInux host eth1.

I have pointed/re-installed the sim to use eth1, and the interface is down on the host, and is in promiscuous mode - is that correct ?.


I have created ns0, and ns1 on the sim with different IP addresses to the eth1 address on the host - is that correct ?.


Still get the pf_packet_write: write packet: No such device messages, but they stop after a couple of minutes.


However, when I try and ping an IP address, I get: -


ping: wrote 10.xx.x.xx 64 chars, error=No route to host
ping: wrote 10.xx.x.xx 64 chars, error=No route to host
ping: wrote 10.xx.x.xx 64 chars, error=No route to host
ping: wrote 10.xx.x.xx 64 chars, error=No route to host


and no more pf_packet_write: write packet: No such device


Changed /etc/rc.local on the Linux host to point to eth1.


So, I guess somewhere there is a routing/network issue.

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner