Simulator Discussions

ONTAP simulator 8.1.2 on VirtualBox

Following the excellent instructions provided for the 8.1.1 simulator (located at I've tried to recreate with the 8.1.2 simulator.


The idea is the same, create a FreeBSD_64 vm, attach the disks in the same order as the vmx file from the virtualplayer image describes to the IDE bus, add serial ports with redirect, no audio device, 4 nics, etc.


The VM will boot up fine, but then it will error with "Cannot open env/env" and



Unable to read environment from CF card!

Please re-create your VM environment.




I've noticed that there is a cfcard directory provided in the download and it contains the env/env file that then has all the environment settings.


Any VMWare wizards in the house that can shed some light on how this file is being accessed from the vm?







Re: ONTAP simulator 8.1.2 on VirtualBox


try to press CTRL-C when prompted when booting the VM to get into the ONTAP-boot-menue. There, choose point 4 to reset the filer and start over.

After booting, the initial setup should begin.

Re: ONTAP simulator 8.1.2 on VirtualBox

It's not even giving me the 10 second countdown, BTX loads and boots straight into the VLOADER prompt.

Re: ONTAP simulator 8.1.2 on VirtualBox

I'm not 100% sure, but I think, I took the nvram-flat.vmdk-File instead of nvram.vmdk in the configuration.

I look into my private VirtualBox-config tonite on my Mac. There, the ONTAP-Sim 8.1.2 is up and running...

So spent a little patience please

Re: ONTAP simulator 8.1.2 on VirtualBox

Here is my configuration with VirtualBox 4.2.6 an ONTAP-Simulator 8.2.1:

Re: ONTAP simulator 8.1.2 on VirtualBox

Used the screenshots and finally (started months ago) have the Simulator working in VirtualBox!


Re: ONTAP simulator 8.1.2 on VirtualBox

How did you fix this error? I'm having the same problem with the ONTAP8.2 sim using Virtualbox 4.2.16 on Mac OS X.

Re: ONTAP simulator 8.1.2 on VirtualBox

I could also use some info on this magical cfcard feature.  I'm trying to bring it up in KVM and it is complaining about this.

I  am thinking that I can put the cfcard files on a small vfat image and  use the -usb option, but I would prefer not to if possible.



Re: ONTAP simulator 8.1.2 on VirtualBox

I was never able to get this to work. From the other thread I had matched the same screenshots as posted above. I am running virtualbox on a linux host if that makes any difference. In the end I installed vmware workstation and bridged the virtual network back to the virtualbox bridge adapter so I can still use virtualbox for the existing virtual infrastructure I already have.

Please let us know if you find anything about the cfcard.

Re: ONTAP simulator 8.1.2 on VirtualBox

Chris -

Something to double check, as I even missed this as I'm tonight setting up an 8.2 sim - make sure your virtual machine includes a "floppy" controller with a single "empty" drive.  It's actually very important because disk number inside the virtual machine is affected by the presence, or lack of presence, of a floppy controller.

If you just follow the VMX contents for which disks to attach to which IDE controller, it's easy to miss the floppy drive which is a default part of the VMWare Machine definition in version 7.  Missing the floppy drive setup will cause the CFCard issue exactly as you have described it.


View solution in original post

Re: ONTAP simulator 8.1.2 on VirtualBox

Thanks Bob! This worked. I had the floppy controller but not the "empty drive".

Re: ONTAP simulator 8.1.2 on VirtualBox

Thanks Bob!

Re: ONTAP simulator 8.1.2 on VirtualBox

FYI, when I had this error, I forgot to add the empty floppy to the floppy controller.  Adding that allowed the simulator to run properly.

Re: ONTAP simulator 8.1.2 on VirtualBox

OS: openSUSE 42.1

VM: Qemu 2.6.0





tar xf vsim-netapp-DOT9.0RC1-cm.ova
for i in *.gz; do gunzip -k "${i}"; done for i in *.vmdk; do qemu-img convert -f vmdk -O qcow2 "${i}"; done


Qemu command:


qemu-system-x86_64 \
-boot order=c,menu=on \
-drive if=floppy,index=0 \
-drive file=vsim-netapp-DOT9.0RC1-cm-disk1.qcow2,media=disk,if=ide,index=0,format=qcow2 \
-drive file=vsim-netapp-DOT9.0RC1-cm-disk2.qcow2,media=disk,if=ide,index=1,format=qcow2 \
-drive file=vsim-netapp-DOT9.0RC1-cm-disk3.qcow2,media=disk,if=ide,index=2,format=qcow2 \
-drive file=vsim-netapp-DOT9.0RC1-cm-disk4.qcow2,media=disk,if=ide,index=3,format=qcow2 \
-drive media=cdrom,if=scsi,index=0 \
-device e1000-82545em,id=e1000-82545em.0,mac=52:54:00:00:00:01,vlan=1 \
-net tap,script=no,downscript=no,ifname=tap1,vlan=1 \
-device e1000-82545em,id=e1000-82545em.1,mac=52:54:00:00:00:02,vlan=2 \
-net tap,script=no,downscript=no,ifname=tap2,vlan=2 \
-device e1000-82545em,id=e1000-82545em.2,mac=52:54:00:00:00:03,vlan=3 \
-net tap,script=no,downscript=no,ifname=tap3,vlan=3 \
-device e1000-82545em,id=e1000-82545em.3,mac=52:54:00:00:00:04,vlan=4 \
-net tap,script=no,downscript=no,ifname=tap4,vlan=4 \
-cpu host \
-smp 2 \
-m 8192 \
-enable-kvm \
-vga cirrus \
-k de \
-rtc base=utc \
-nodefaults \
-serial vc \
-display gtk \


It's starting to boot. But after about a minute it's giving me this:








































2016-08-18 update: Adjusted NIC config (e1000-82545em instead of e1000). Further KVM/Qemu stuff here:

Re: ONTAP simulator 8.1.2 on VirtualBox

When you get the "press ctrl-C" banner, press ctrl-C.  Then you'll get the boot menu, pick option 4 to initialize the system.


If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Review Banner
All Community Forums