Simulator Discussions

Ontap simulator 9.6 vol0 full

NickRedstar

I installed ontap 9.6 simulator and my vol0 ran out of space. I disabled all the snapshots on aggregate and volumes and still did not help.

-Node cluster1-02 is in an unhealthy state

-aggregates for cluster1-02 are showing in unknown state

-Resizing does not work of the vol0

-rebooted the node multiple times

::>

Vserver Volume Aggregate State Type Size Available Used%

cluster1-02 vol0 aggr0_c1N2 online RW 807.3MB 26.45MB 96%

 

1 ACCEPTED SOLUTION

Ontapforrum

Hi,

 

You haven't mentioned if you tried deleting the vol0 snapshots. Disabling will prevent further snaps, but if there are already existing then you can get rid of them.

 

cdot-01> snap delete -a vol0
Are you sure you want to delete all snapshots for volume vol0? y

 

Assuming you gained space after deleting snaps.

cdot-01> df -hg vol0

 

If it has?

 

Then, re-size it before rebooting.

cdot-01> vol size vol0 +1g

 

I Usually keep min 2g for vol0, always take a vmware snap before using it.

 

Let us know.

 

Thanks!

 

View solution in original post

3 REPLIES 3

Ontapforrum

Hi,

 

You haven't mentioned if you tried deleting the vol0 snapshots. Disabling will prevent further snaps, but if there are already existing then you can get rid of them.

 

cdot-01> snap delete -a vol0
Are you sure you want to delete all snapshots for volume vol0? y

 

Assuming you gained space after deleting snaps.

cdot-01> df -hg vol0

 

If it has?

 

Then, re-size it before rebooting.

cdot-01> vol size vol0 +1g

 

I Usually keep min 2g for vol0, always take a vmware snap before using it.

 

Let us know.

 

Thanks!

 

View solution in original post

NickRedstar

thanks, i deleted the snapshots on vol0.It looks like that it took some time for the simulator to recognize that snapshots were deleleted. I left my simulator running over night and rebooted it in the morning. Finally the node 2 started working again. I logged in to ONTAP system manager and Aggregate0 was showing full , so  i added extra disks in order to increase space. 

Overall your steps are correct in resolving this vol0 being full issue. Thanks for your help.

Ankitr1

The issue that you faced is very common with the simulators

To avoid this in future you can also disable the snapshots on the root vol  using the command from node shell 

Cluster1-01> snap sched vol0 0 0 0

Cluster1-01> snap sched vol0

Volume vol0: 0 0 0

Once you do this you wont have to worry about the root vol being full due to snapshots.

 

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public