Simulator Discussions

Simulator Update 8.3 -> 9.1


When attempting to update the image for the simulator using the following command:


cluster:>> system node image update -node * -package <url> -replace image2


I get the following error and don't know what needs tweaking.


Error; command failed on node <node name>: install Failed.  Cannot update or install image because the system management storage area is almost out of space.  To make space available, delete old Snapshot copies.  For further assistance, contact technical support.


What do I need to adjust to get this updated sim image installed?  The root aggrs on the 2 nodes have 10GB free currently.


Any help or guidance appreciated.


Re: Simulator Update 8.3 -> 9.1


Nevermind ... Option 7 did the trick.


Smiley Embarassed

Re: Simulator Update 8.3 -> 9.1


Well, I spoke too soon Smiley Sad


Turns out one of my nodes was able to download the 9.1 image successfully through option 7, but not the other.  Really wierd.  So I have poked around and in the /cfcard directory (via systemshell) there is an env directory that holds an env file.  There is one particular bootarg that seems to get set when invoking Option 7:


setenv bootarg.install.ramdisksize "512M"


I don't know enough about the sim to know how this comes into play, but I'm guessing this is used to create an area where the new image can be downloaded from my http server.  The reason I think so is, using HFS, I can see the node get about 65% through downloading the image when it fails due to the /mnt filesystem being full.  That is right at 512MBs of data having been transferred when it barfs.  The actual 91_q_image.tgz is 777MB.


I tried editing this to create a larger RAM disk, but the value was changed back somewhere in the sequence to 512M, as it failed again at the exact same point.


My /cfcard filesystem has 1.4GBs free and the 9.1 image is only 374MBs on the node where it successfully downloaded.  I've looked for differences in the various filesystems (again via systemshell) and there just isn't anything significant ... all very minor.  BTW, i tried an 8.3.2 image and got the same results.  It also exceeded 512M ... as it is 527M,


Anyone have any ideas as to what may be going on here?  Really odd that my other node had no issue with Option 7.

Re: Simulator Update 8.3 -> 9.1


From within your simulator, check the free space on the root volumes.  You may need to exapnd the root vols, or clean up some files there.  When you do the system node image get from inside ONTAP, it puts it in mroot.  When you do it from option 7, it downloads to ramdisk, then extracts to the cfcard.  If you stick with the option 7 route, try setting that bootarg when it reboots after picking option 7.


If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

View solution in original post

Re: Simulator Update 8.3 -> 9.1


I wanted to say THANK YOU! ... for helping.  I was able to create the larger RAMDISK at the LOADER> prompt after invoking the Option 7.  I did set it to 1024m ... in order to ingest the larger 9.1 image.


My 2-node cluster is running on my MacBook Pro and I am a happy camper.


Thanks again!

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums