Simulator Discussions

Simulator in Amazon Cloud?


Hello Everyone,


Curious if anyone has attempted to load the OnTap Simulator in Amazon C3 Cloud?  My MacBook Air only has 4 GB of RAM not meeting the 5GB requirements and yard sales when attempting to boot.


Thanks for anyone's input, much appreciated.  


Hack the Planet,




Getting the sim into an AMI instance would be a nice hack.


But if you were going to run it there you might as well spin up ONTAP Cloud.  You give up the simulated disks/shelves and software raid, but you gain the option to do HA.


Back on the macbook front, 4gigs is really tight.  It might start if you drop the VM to 3GB and start it shortly after a reboot before ram starts to get wired.  Fusion by default is optimized for performance, not density.  You can disable disk buffering which may free up a tiny bit, but you may still need to enable memory overcommitment.    William Lam has a writeup on his blog:


If you allow 50% memory overcommitment it just might boot.



If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.


Thank you so much for your reply!  I'll let you know if I get it working in the cloud.


After digging around in the EC2 Cloud, which I am totally new to, I don't see how I can import the OVA Ontap Simulator file as a AMI due to OVA imports must be Windows or Linux based.  The NetApp simulator is BSD so I don't see this working, however I didn't test it.  It doesn't seem straight forward on how to import a OVA file.  


As far as Ontap Cloud, Amazon already has a preconfigured instance already setup for $.112 per hour.


My other option at this point is to get a Windows instance on EC2 and install VMware Workstation, then the sim loaded. 


Any other options or am I way off base?  Again, new to NetApp and Amazon...  My agency just bought NetApp and looking for a off-prim training lab resource.


Thanks for your help,



I doubt nested virtualization would be enabled in a windows instance.  There may be a vcloud providor that could import the ova, but thats not something I've ever explored, and honestly probably isn't the best way to get started.  There are trials on both Amazon and Azure that might be a better place to start:


But the free option is to scale it down to run on your laptop, or find another compute resource to run it on.  

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.


Thank you for your response.  I think I am leaning towards running Ontap Cloud in Amazon at this point and giving up on the Simulator idea. Thank you for input regarding the Windows VM idea. 




Quick update trying to get the NetApp Ontap Simulator to run in the Amazon EC2 Cloud.


What I have tried so far:


My first thought was to see if Amazon EC2 could import the OnTap simulator's OVA file and start and Bob's your uncle.  Seemed reasonable to me at first.  First off importing a OVA file in EC2 isn't a point and click operation, it requires some json magic which I'm not familiar with yet the instructions seemed pretty straight forward, well sort of 🙂  I created some groups, and started down the that rabbit hole until I started to realize that this effort wouldn't work because the sim, like Ontap on our arrays is running BSD under the covers.  Pretty awesome, a huge fan of BSD myself, but Amazon's instances are from what I understand like docker instances and share a common Linux and Windows kernel.  That being said, BSD just isn't an option and now it makes sense why.


I moved on to option 2, which was spin up a Windows 2012 server and install VMplayer on it then import the OVA file and next we are eating  bowl of butter popcorn and a cholate shake from Alamo Drafthouse to celebrate... Well, that didn't work out after a few hours of work not to mention no celebration deserts and seeing The Arrival. Boo


Steps I took for option 2

  1. Spun up a Windows 2012 R2 instance with t2.large configuration to support the RAM requirements (success)
  2. Once logged in to my Windows instance, I downloaded and installed VMplayer (success)
  3. Imported the OnTap simulator OVA file and converted it using VMWare Player (success)
  4. Hit the play button to boot the simulator BSD instance of OnTap and VMware Player throws an error message: VMware Workstation and Hyper-V are not compatible. Remove the Hyper-V role from the system before running VMware Workstation (epic fail)
  5. Start to troubleshoot this issue and attempt to disable Hyper-V via the command line with administrator privs.
    1. bcdedit /set hypervisorlaunchtype off
    2. reboot
  6. Still not working, same error message.

Theory:  Perhaps VMware Player knows the 2012 instance I am running is virtual itself and won't allow virtual-->virtual-->virtual.


This is where I am at so far...  Cheers


Just for fun, I spun up an OSX Sierra instance in a VM with 4gb ram, enabled nested virtualization, and installed VMware Fusion inside the VM.  By dropping the simulator RAM to 3gb I was able to start it and get through a basic configuration.  I didn't have to enable memory overcomittment in the nested Fusion instance.  I kept all the defaults except the RAM allocated to the simulator VM.


You should be able to do the same on your 4GB Macbook air.



If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.


Good info here. I just wanted to add an experience I had to warn others.


I started playing with AWS on and off about a year and a half ago. I used up my one-year-free time. Then I started playing with Cloud ONTAP and I was willing to pay for the limited time I had it up and running. When my attention moved on to other things I did remember to make sure my Cloud ONTAPs were shutdown and not running. However, a few months later I realized I was still getting a hefty automatic monthly bill, around $100. I can't remember all the steps I had to take to stop it (delete some underlying images or such) but watch out for that.


I'd be interested to hear if AWS has some low-level fixed 'Lab' type yearly billing structure for us lab-rats. 


PS: my intentions were to build a WFA lab and I got enough built and tested to confirm it is clearly possible. Cloud ONTAP responds to API calls just as you'd expect. I'd still like to move in that direction in the future.


Thank you for your post!  This was my next approach was to spin up the pre-configured Cloud OnTap instance but was a little concerned about the pricing.  I'm glad you posted this.  By the way, I agree that if these have APIs we might be able to script out a base config and spin up the instance and populate the config, well all in theory.  Please keep me posted of any progress you make. 





I can confirm, you cannot run the simulator on AWS, at least not natively.  Virtualization is not possible since the virtualization instructions are disabled on AWS's VM's.  It MAY be possible using this:



Hi, FYI, Looks like NetApp has an option to try Cloud OnTap in AWS and get a free $100 AWS credit/voucher. Take a look at  . I have run the Ontap 7.3 and 8.2 Simulators on laptops that were beefed up with 32 GB of RAM, but I too have been curious about running an OnTap 9.x Simulator on AWS ( or another cloud platform).