Simulator Discussions

Snapmirror with Simulators


Using either version 8.3 or 9 of the simulator, I am able to configure snapmirror between clusters using vmware workstation and player. However once it is done on ESX I am unable to peer the clusters.

Cluster Peer health show says ICMP ok but Data unavailable.  This has been tested with a single host and an isolated vswitch as well as across multiple hosts.

vsphere 6 is the host version. (also this was tested using both the workstation and ESX build of the simulator with similar results.)







There might be numerous reasons for this error, what i suggest is to check if the clock on both the controllers is in sync +/- 300 secs,  Validate network configuration ?. Please follow this KB to narrow down your issue.






Hum ... fwiw, I've got what you're trying to do working (vsim 8.3.2 clusters peered on ESX6). I'd double-check assumptions on the ESX VM settings for it's 4 network adapters. Are e0a, e0b, e0c, e0d really on the networks you think they are? You didn't mention if your ESX6 vsims are single or dual-mode and I 'think' vsim setup makes different choices for what networks e0a|b|c|d are assumed to be used for (cluster network vs. vm (mgmt/data) network. FWIW, even though I run single-node clusters I've got e0a&b on cluster network (not used) and e0c&d on VM network. The key to your problem would be around your intercluster LIF for each node and what port it sits on.


Having said the above, I have vague recollection of a  real-world customer having peering problems with an error similar to "Cluster Peer health show says ICMP ok but Data unavailable". As I remember it came down to an MTU size issue. The customer's net was 'not fully' allowing MTU=9000 packets on the path peering was going over. If you're doing anything like raising the MTU size above 1500 that might be worth looking into. There are some options on the ping command that let you explicitly pick the outbound LIF and icmp packet size which you could use to see if it's anything related to that.