Simulator Discussions

invalid file system when trying to mount a volume on the simulator to my Mac

ToddErickson
417 Views

Hello,

I am new to NetApp and the Simulator. I am running the simulator in Fusion on my Mac.  I worked through the Simulate ONTAP 9.7 Installation and Setup Guide.  When I try to mount a volume on the simulator onto my Mac using

mount -t nfs 192.168.1.102:/volume1 /mnt/netapp

I get:

mount: /mnt/netapp: invalid file system.

 

showmount -e 192.168.1.102 returns:

Exports list on 192.168.1.102:

/                                   Everyone

/volume1                            Everyone

 

Any guidance or help would be appreciated.

2 REPLIES 2

darr613
379 Views

Hello Tod,

I believe the -a parameter refers to the filesystem extension
most Linux use ext, ext2, ext3, ext4

You could try mounting it in the fstab file

Create the /svm1 directory to serve as a mounting point for the NFS volume you will be mounting.
[root@rhel1 ~]# mkdir /svm1

Add an entry for the NFS mount to the fstab file.
[root@rhel1 ~]# echo "svm1:/ /svm1 nfs rw,defaults 0 0" >> /etc/fstab

Verify the fstab file contains the new entry you just created.
[root@rhel1 ~]# grep svm1 /etc/fstab
svm1:/ /svm1 nfs rw,defaults 0 0

Mount all the file systems listed in the fstab file.
[root@rhel1 ~]# mount -a

View a list of the mounted file systems.
[root@rhel1 ~]# df

Navigate into the /svm1 directory.
[root@rhel1 ~]# cd /svm1

Notice that you should see the volume that you previously junctioned into the SVM's namespace.
[root@rhel1 svm1]# ls /svm1

SeanHatfield
287 Views

did you create the /mnt/netapp directory first?

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Public