Software Development Kit (SDK) and API Discussions

How do I access the DFM WSDL API


Hi, I'm running NetApp OnCommand (5.2) and would like to programmatically access the netapp data using the webservices API. DFM is currently listening on ports 8080, 8088, 8443 and 8488 but I can't seem to get any useful response other than a 404 'Not Found'. I've tried accessing the web services API via apis/soap/v1 and /apis/XMLrequest on the above ports using a combination of http and https and nothing returns anything useful

Does anyone know how this should work? Should I get a response from those URLS and ports or do I need to post data before getting a response?



Re: How do I access the DFM WSDL API



How are you trying to access the WebServices?

What programming language are you using to invoke the WebServices?

There are some sample codes (under <nmsdk root>/src/sample/DataFabric_Manager/WebServices) which shows how you can invoke  WebServices using Apache CXF and .NET. You can also try out some external tools (like soapUI) to test the WebServices without writing any code.

Please let me if you have more questions on this.



Re: How do I access the DFM WSDL API


Hi sens, I'm trying to do a simple SOAP request using PHP, the xml I am posting is:

<SOAP-ENV:Envelope xmlns:SOAP-ENV="" xmlns:na="">






The response I get back is:

<?xml version='1.0' encoding='UTF-8' ?>

<!DOCTYPE netapp SYSTEM 'http://<ip>:8088/netapp_server.dtd'>

<netapp version='1.0' xmlns=''>

<results reason="No netapp element in API request" errno="13001" status="failed"/></netapp>"

Re: How do I access the DFM WSDL API


Doesn't work using SOAPUI either:


Time Taken: 175

Size: 268

Timestamp: Tue May 13 16:56:44 BST 2014

TestStep: AggregateListInfoIterStart

----------------- Messages ------------------------------

----------------- Properties ------------------------------

Encoding: UTF-8



Endpoint: http://url:8080/apis/XMLrequest

---------------- Request ---------------------------

Request Headers: Authorization : Basic dGNveDpEZk0xMlI1QGRPbkx5

Host : url:8080

Content-Length : 1470

SOAPAction : "urn:AggregateListInfoIterStart"

Accept-Encoding : gzip,deflate

User-Agent : Apache-HttpClient/4.1.1 (java 1.5)

Connection : Keep-Alive

Content-Type : text/xml;charset=UTF-8

<soapenv:Envelope xmlns:soapenv="" xmlns:v1="">




         <!--You may enter the following 13 items in any order-->



























            <!--1 or more repetitions:-->






---------------- Response --------------------------

Response Headers: Date : Tue, 13 May 2014 15:56:44 GMT

#status# : HTTP/1.1 200 OK

Content-Length : 268

Keep-Alive : timeout=60, max=499

Connection : Keep-Alive

Content-Type : text/xml

Server : libzapid-httpd

<!DOCTYPE netapp SYSTEM "http://ip:8088/netapp_server.dtd">

<netapp version="1.0" xmlns="">

   <results reason="No netapp element in API request" errno="13001" status="failed"/>


Re: How do I access the DFM WSDL API



Actually the Endpoint (http://url:8080/apis/XMLrequest) that you have used is wrong. It is used for the usual Zephyr API communication and not for SOAP API.

The correct Endpoints for SOAP are:

for http:   http://HOST_NAME:8088/apis/soap/v1

for https: https://HOST_NAME:8488/apis/soap/v1

Please let me know if it worked after modifying the endpoint.



P.S.: Replace the HOST_NAME with the IP address of the DataFabric Manager server.

View solution in original post

Re: How do I access the DFM WSDL API


Works perfectly and in PHP using soapclient - thanks!

Re: How do I access the DFM WSDL API


I am getting the same exception(No elements in API request) in Java using ONTAP API 8.2.2 and NMSDK 5.3 jar versions.

new ApiRunner(ApiTarget.builder().withHost(host).withUserName(user).withPassword(pwd).withTargetType(TargetType.FILER).useProtocol(protocoll).build());
and protocol is either Protocol.INSECURE_HTTPS (or) Protocol.HTTP

Suggest us in this regard. Thank You.

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums