Software Development Kit (SDK) and API Discussions

New-NcCluster fails on ONTAP 9.1 simulator


I am working with the ONTAP 9.1 simulator and PSTK 4.4 to test cluster build automation scripts.

When I run the New-NcCluster -ClusterName $cluster_Name -License $base_license, it fails silently.

The node name changes but no cluster is actually created.


Get-NcClusterCreateProgress gives the following message.


CurrentStatusMessage : Unused cluster ports exist in the cluster. One or more ports may not be in the "healthy" state,
                       or may be incorrectly assigned to the "Cluster" Ipspace. Run "network port show -ipspace
                       Cluster" to view the cluster ports. Correct any issues, and then try the command again.
IsComplete           : False
NcController         :
Status               : failed
IsCompleteSpecified  : True



This does not appear to do the magic that all of the PowerShell automation examples proclaim.

Could this be a quirk with the simulator?  Is there more work to be done before creating the cluster? If so, what is it?


I have not been able to do testing on a physical system yet, so I don't know if this behavior is the same or different.






I moved the two default Cluster ports (e0a and e0b) from the Cluster IPspace to the Default IPspace and New-NcCluster worked.


If I wanted to use those ports for cluster interconnects, what would be the procedure? Do I assign IP addresses to them before creating the cluster or do I move the ports to the Default IPspace, create the cluster and configure the ports as cluster ports in the Cluster IPspace?


How does this behave on a physical filer? Is this a quirk of the simulator?






Hi ronaldmajor

have you resolve the problem?

I use the simulator 9.10

and still have the same problem

So I want to ask you the solution if you have