Software Development Kit (SDK) and API Discussions

Puppet - NMSDK 5.7 with ONTAP 9.1P11 fails with "Unable to find API: cluster-identity-get"

All, we are trying to do a POC for Puppet and are encountering the following issue:

 

 

Unable to find API: cluster-identity-get :: ONTAPI :: Error

 

 

This was working properly under ONTAP 9.1P3. IMT doesn't help. Has anyone seen this or know a solution/workaround? 

 

Details:

ONTAP: 9.1P11

NetApp NMSDK: 5.7 

Puppet Master Version: 2016.5.2
Puppet Agent: 4.8.2

Faraday Gem: Installed; '0.13.1', '0.9.2'

9 REPLIES

Re: Puppet - NMSDK 5.7 with ONTAP 9.1P11 fails with "Unable to find API: cluster-identity-get&q

 

I was wondering, if it would be possible for you to share the device.conf, the hostname of the cluster(hostname command on ONTAP) , the FQDN of the cluster and the node name used in the manifest?

 

PS: Feel free to exclude sestive information like password

Re: Puppet - NMSDK 5.7 with ONTAP 9.1P11 fails with "Unable to find API: cluster-identity-get&a

[root@nc2dlpupagt01 puppet]# cat netapp_device.conf

[nc2dacstore01-01]

type netapp

url https://sa-napuppet:<redacted>@nc2dacstore01-01:443

 

FQDN: nc2dacstore01-01.us.ad.lfg.com

Re: Puppet - NMSDK 5.7 with ONTAP 9.1P11 fails with "Unable to find API: cluster-identity-get&a

Does the sa-napuppet user have cluster admin functionality ?

You can try a  "security login role show" to verify this

 

Also, I asusme u are using 
node nc2dacstore01-01 {

//resource types

}

 in your manifest?

 

Re: Puppet - NMSDK 5.7 with ONTAP 9.1P11 fails with "Unable to find API: cluster-identity-get&a

Yes, you're correct. It has cluster admin for both "ontapi" and "http" applications only.

 

Yes, you're also correct regarding the manifest.

Re: Puppet - NMSDK 5.7 with ONTAP 9.1P11 fails with "Unable to find API: cluster-identity-get&a

In the error text you sent, i see

8503ea00000001a5 :: nc2dacstore01:ontapi :: 10.65.40.63:53752 :: svm_test:sa-napuppet :: Unable to find API: cluster-identity-get :: ONTAPI :: Error

 

Its trying to run cluster-identity-get (which is a cluster scoped API). I wonder where is svm_test listed. Is it in the device file or manifest ?

Re: Puppet - NMSDK 5.7 with ONTAP 9.1P11 fails with "Unable to find API: cluster-identity-get&a

Why is a cluster-scoped command going to an SVM (svm_test)? How do we workaround this?

Re: Puppet - NMSDK 5.7 with ONTAP 9.1P11 fails with "Unable to find API: cluster-identity-get&a

Are you sure it is not listed in any of your Puppet files, device or manifest ?

 

 

Re: Puppet - NMSDK 5.7 with ONTAP 9.1P11 fails with "Unable to find API: cluster-identity-get&q

cat /etc/puppetlabs/puppet/netapp_device.conf
[nc2dacstore01-01]
type netapp
url https://sa-napuppet:<redacted>@nc2dacstore01-01:443

[svm_test]
type netapp
url https://sa-napuppet:<redacted>@nc2dacstore01-01/svm_test

Re: Puppet - NMSDK 5.7 with ONTAP 9.1P11 fails with "Unable to find API: cluster-identity-get&q

I think i see the misconfig in your file.

[svm_test]

type netapp
url https://sa-napuppet:<redacted>@nc2dacstore01-01/svm_test

 

The URL should be 

url https://sa-napuppet:<redacted>@svm_test_FQDN/svm_test ..Where svm_test_FQDN resolves to the mangement IP of your svm_test. Refer to table 11) on page 28 of https://www.netapp.com/us/media/tr-4477.pdf

 

let me know if this works.

Forums