Software Development Kit (SDK) and API Discussions

QtreeSizeInfo Always Null from Web Service API Request

samz_alloys

I believe there may be a bug in the DFM Web Services API.

I'm trying to make a request to the "qtree-list-info-iter-*" API via the Web Services and I'm getting back nulls for the QtreeSizeInfo object off of QtreeInfo objects that should have size information.

When I use the "standard" API method (NaElement, etc.) the same qtree returns data for size info.

Has anyone had a similar problem?

We've tried with all options on and a few other combinations, but haven't had any success.

3 REPLIES 3

christin

This sounds like a support related question. If you have an active NetApp Support login, there are subject matter experts in the NetApp Support Community that may help answer your questions.

If this is an urgent issue please open a case with NetApp Technical Support.

Regards,

Christine

samz_alloys

No, this isn't urgent we have a workaround using the non-SOAP-based API.

I believe our SE has a bug filed with the development team.

Thanks for the suggestion.

samz_alloys

I am curious,

Where in the NetApp Support Community I should look for assistance?

I haven't found where would be a good place to look for API/development related information or support on that site.

christin,https://forums.netapp.com/community/support

Any guidance would be helpful.  Feel free to PM me if you prefer.

Thanks.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public