Software Development Kit (SDK) and API Discussions

SMI-S 5.2.4 libpegcliutils.so.1 error

I installed all pre-reqs including '2:tog-pegasus-libs-2.14.1-7.el7.x86_64', but, I received an error when installing SMI-S. It complained about 'libpegcliutils.so.1'. So I installed the x86 version '2:tog-pegasus-libs-2.14.1-7.el7.i686' and everything is working. Should I make modifications and revert to the x86_64 version?

1 REPLY 1

Re: SMI-S 5.2.4 libpegcliutils.so.1 error

Hi,

 

This thread discusses probably similar issue. User was able to fix it by adding the path of the library to the ld.so.conf file.
https://community.netapp.com/t5/Software-Development-Kit-SDK-and-API-Discussions/SMIS-issue/td-p/126472

 

Can you give that a try (User hasn't mentioned which version of SMI-S was complaining).

 

I am not 100% sure if SMI-S 5.2.4 is a 32-bit or 64-bit application ( I guess you check it from linux command), but it can be installed on 32 or 64-bit Linux OS, and for 64-bit OS as long as the 32-bit library dependencies are met, it should be ok.

 

Thanks!

Try the new BETA Support Site!
Beta Support Site
Forums