Software Development Kit (SDK) and API Discussions

System Latency counter is not getting any value although it has LUN and Volume Latency.

Shivang

I am getting data from ONTAP cluster 8.2.3 simulator and comparing it with 8.3.2 simulator(fields). As this data is coming from a simulator, I have created LUN on this and mapped it with my local windows server to generate data.

 

I am getting  values into "avg_write_latency",  "avg_latency" counters for Lun Object using below CLI command:

statistics show-periodic -object Lun -instance <my_lun_instance> -counter avg_write_latency|avg_latency

 

but still I am not getting any value(except 0ms) for latency counters of system object:

 

statistics show-periodic -object system -instance system -counter sys_read_latency|sys_avg_latency

 

Here is counter info for this counter for 8.2.3 cluster-mode:

 

 

            <counter-info>
                <base-counter>write_ops</base-counter>
                <desc>Average latency for all write operations in the system in milliseconds</desc>
                <name>sys_write_latency</name>
                <privilege-level>basic</privilege-level>
                <properties>average</properties>
                <unit>millisec</unit>

 

Here is counter info for this counter for 8.3.2 cluster-mode: "sys_write_latency" counter is deprecated

 

 

            <counter-info>
                <base-counter>write_ops</base-counter>
                <desc>Note: This counter is deprecated and will be removed in a future release.  Average latency for all write operations in the system in milliseconds</desc>
                <is-deprecated>true</is-deprecated>
                <name>sys_write_latency</name>
                <privilege-level>admin</privilege-level>
                <properties>average</properties>
                <unit>millisec</unit>
            </counter-info>

 

 

            <counter-info>
                <base-counter>write_ops</base-counter>
                <desc>Average latency for all write operations in the system in milliseconds</desc>
                <is-deprecated>false</is-deprecated>
                <name>write_latency</name>
                <privilege-level>admin</privilege-level>
                <properties>average</properties>
                <unit>millisec</unit>
            </counter-info>

 

From the above counter info, Can we say that "sys_write_latency" counter is deprecated into ONTAP 8.3.2?

 

How to get write_latency for system into Cluster 8.2.3 simulator?

 

Am I missing something to get these counters? Can anyone please help?

 

0 REPLIES 0
Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public