Software Development Kit (SDK) and API Discussions

Vserver API missing vserver parameter

RaghavaCheruku

Hi, 

 

I am trying ZEDi for first time and trying to create a volume. but I get a error "Vserver API missing vserver parameter"  

when look for the available parameters under "volume-create"  I dont see a parameter where  I can specify the vserver name. can somehelp me to understand where I am going wrong.

 

 

I have attached screenshot as well..

 

 

Thank you in Advance..

 

Raghu

1 ACCEPTED SOLUTION

mbeattie

Hi Raghu,

 

Did you specify the vserver in your ZExplore cluster connection properties? EG (preferences\connect\Set the vFiler\vserver name).

 

zexplore.png

 

/Matt

 

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

View solution in original post

4 REPLIES 4

mbeattie

Hi Raghu,

 

Did you specify the vserver in your ZExplore cluster connection properties? EG (preferences\connect\Set the vFiler\vserver name).

 

zexplore.png

 

/Matt

 

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

View solution in original post

RaghavaCheruku

Hi Matt,

 

thank you for your reply, yes I was able to using the Vserver tunneling to create volume.

 

I have one more question to ask, what is the difference between these two NMSDK versions ?

 

netapp-manageability-sdk-5.X vs netapp-manageability-sdk-9.X

Is there any link that explain the differences between these 2 ?

 

Thank you in Advance.

 

Regards

raghu

mbeattie

Hi Raghu,

 

The difference between the NMSDK versions is the product versions each supports as follows:

    

NetApp Manageability SDK 9.3 includes the following new features:

    Perl API Bindings for ONTAP 9.3
    Perl API Bindings for OnCommand Unified Manager 7.3
    Support for Java 9
    Support for Python 3.6.1

     
NetApp Manageability SDK 5.7 includes the following new features:

    Perl API Bindings for ONTAP 9.2
    Perl API Bindings for OnCommand Unified Manager 7.1 and 7.2
    Upgrading the libxml library from 2.9.2 to 2.9.4

 

/Matt

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

aditya_pandit

Please see my discussion:

Please update NMSDK Sample for error 13006

 

Regards,

Aditya

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public