Software Development Kit (SDK) and API Discussions

snapdiff on vfiler not working

sahara101
684 Views

Hello,

 

I am trying to connect a vfiler on ontap 8.0.3P3 N7700 with SP 8.1.12

Connection for command incremental -spandiff P: does not work at all...

net use connected with the snapdiff_user

Name: snapdiff_p
Info:
Rid: 131081
Groups: snapdiff_group
Full Name:
Allowed Capabilities: login-http-admin,api-*
Password min/max age in days: 0/4294967295
Status: enabled

 

Name: snapdiff_group
Info:
Rid: 131077
Roles: snapdiff_role

 

Name: snapdiff_role
Info:
Allowed Capabilities: login-http-admin,api-*

 

options httpd.
httpd.access legacy
httpd.admin.access legacy
httpd.admin.enable on
httpd.admin.hostsequiv.enable off
httpd.admin.max_connections 512
httpd.admin.ssl.enable off
httpd.admin.top-page.authentication on
httpd.autoindex.enable off
httpd.bypass_traverse_checking off
httpd.enable on
httpd.log.format common (value might be overwritten in takeover)
httpd.method.trace.enable off
httpd.rootdir /vol/vol0/home/http
httpd.timeout 300 (value might be overwritten in takeover)
httpd.timewait.enable off (value might be overwritten in takeover)

 

These are the settings from the netapp vfiler0

Below from the actual vfiler

 

vfiler context p

 

options httpd.
httpd.access legacy
httpd.admin.access legacy
httpd.admin.enable off
httpd.admin.hostsequiv.enable off
httpd.admin.max_connections 512
httpd.admin.top-page.authentication on
httpd.autoindex.enable off
httpd.bypass_traverse_checking off
httpd.enable off
httpd.log.format common
httpd.method.trace.enable off
httpd.rootdir XXX

 

I also tried enabling admin here, but same error.

 

14.02.2022 16:06:20.282 [002940] : ..\..\common\hci\NAHWInterface.cpp(5955): naEstablishConnection(): Opening conection to filer:
server address = p
user = snapdiff_p
SVM name = not set
requested version = 1.5

14.02.2022 16:06:20.282 [002940] : ..\..\common\hci\NAHWInterface.cpp(6036): naEstablishConnection(): Connection successfully opened.
14.02.2022 16:06:20.282 [002940] : ..\..\common\hci\NAHWInterface.cpp(6073): naEstablishConnection(): setting authentication type to LOGIN_PASSWORD .
14.02.2022 16:06:20.282 [002940] : ..\..\common\hci\NAHWInterface.cpp(6081): naEstablishConnection(): setting stored password for user 'snapdiff_p' on filer 'p'...
14.02.2022 16:06:20.282 [002940] : ..\..\common\hci\NAHWInterface.cpp(6124): naEstablishConnection(): getting filer version string ...
14.02.2022 16:06:21.305 [002940] : ..\..\common\hci\NAHWInterface.cpp(6137): naEstablishConnection(): system-get-version: failed: rc=10061, reason='Can't connect to host (err=10061).'
14.02.2022 16:06:21.305 [002940] : ..\..\common\hci\NAHWInterface.cpp(6146): naEstablishConnection(): authentication error.
14.02.2022 16:06:21.305 [002940] : ..\..\common\hci\NAHWInterface.cpp(6214): naEstablishConnection(): returning 6130.
14.02.2022 16:06:21.305 [002940] : ..\..\common\hci\NAHWInterface.cpp(8325): hwSystemInit(): Error connecting to filer. Exiting with rc = <6130>

 

What can I do?

 

Thanks!

1 ACCEPTED SOLUTION

Ontapforrum
666 Views

IBM SP 8.1.12 (or later) requires minimum c-mode 8.3.x and later. You are running a 7-mode data ontap which is not supported.


IBM Spectrum Protect™ Backup-Archive Client supported levels of NetApp Data ONTAP:
https://www.ibm.com/support/pages/ibm-tivoli%C2%AE-storage-manager-and-ibm-spectrum-protect%E2%84%A2-backup-archive-client-supported-levels-netapp-dat...

View solution in original post

2 REPLIES 2

Ontapforrum
667 Views

IBM SP 8.1.12 (or later) requires minimum c-mode 8.3.x and later. You are running a 7-mode data ontap which is not supported.


IBM Spectrum Protect™ Backup-Archive Client supported levels of NetApp Data ONTAP:
https://www.ibm.com/support/pages/ibm-tivoli%C2%AE-storage-manager-and-ibm-spectrum-protect%E2%84%A2-backup-archive-client-supported-levels-netapp-dat...

sahara101
657 Views

ah...how did I miss that....so then my only solution is NDMP? 

Public