SolidFire and HCI

Net-APP HCI Jumbo Frames

Mrfall
985 Views

Hello Folks!

I am trying to change the MTU on Storage And Compute but one of the nodes doens't like to change the MTU to 9000 I tried many times.. I also I restart the Nodes. Is any way  get this work Done ?

1 ACCEPTED SOLUTION

Mrfall
881 Views

I really appreciate your help and thoughts.

for jumbo frame, I get jumbo frame setup by changing from dhcp to static and jumbo frame working fine now.

for the gateway invalid  I found there is a bug on NDE 1.80.25 and you have to use d-patch to solve this error and i got it solved.

You can see this article for the issue

 https://kb.netapp.com/Advice_and_Troubleshooting/Hybrid_Cloud_Infrastructure/NetApp_HCI/%22The_gateway_is_not_valid%22_during_NDE

View solution in original post

4 REPLIES 4

Mrfall
950 Views

Also I have Issue With Network Settings

The default Gateway "The gateway is not valid." For the MGMT network on compute

I am using NDE 1.8

elementx
884 Views

It is tricky to change MTU to a smaller value because that means all nodes can't send non-fragmented packets to the node that changes to a smaller MTU, and especially with SolidFire (or clusters in general) by doing that you essentially take a node's interface down and with it put the node out of service (iSCSI interface)

 

On top of that there's also VMware which is configured to use MTU 9000 so once you change SF to 1500 your ESXi and VMs and vCenter will drop.

 

There are several articles about this in the KB

 

https://kb.netapp.com/Special:Search?query=change+mtu+hci&type=wiki

 

It's best to read them, create a plan and check with Support if the steps are OK, then do it during scheduled downtime.

 

> The default Gateway "The gateway is not valid." For the MGMT network on compute

 

Maybe your gateway isn't pingable or is on a different (unreachable) VLAN.

Depending on VMware vSwitch configuration and one of several approaches to networking (VDS/VSS, 2 cable, 4 cable,  all Host Tagged VLANs, or some Host Tagged VLANs), there are different problems that people run into.

You'd have to describe which approach you took and how you configured your network for it, etc.

Mrfall
882 Views

I really appreciate your help and thoughts.

for jumbo frame, I get jumbo frame setup by changing from dhcp to static and jumbo frame working fine now.

for the gateway invalid  I found there is a bug on NDE 1.80.25 and you have to use d-patch to solve this error and i got it solved.

You can see this article for the issue

 https://kb.netapp.com/Advice_and_Troubleshooting/Hybrid_Cloud_Infrastructure/NetApp_HCI/%22The_gateway_is_not_valid%22_during_NDE

elementx
879 Views

Okay, then. 

 

MTU 9000 is definitively preferred to smaller MTU, good to hear that was sorted out.

Public