VMware Solutions Discussions

[BETA] Using VVOLs with NetApp & VMware

UPDATE [Apr 9 2015]: The official versions of both VSC 6.0 and VASA Provider 6.0 are available as of today.







We want to hear your feedback!  We would love to consolidate everything centrally here in this thread, but if you have something that you don't want to say in the communities, you can always send VSC feedback to xdl-vsc-feedback@netapp.com.


-NetApp VSC/VASA team-

102 REPLIES 102

Re: [BETA] Using VVOLs with NetApp & VMware

Thank you for opening the beta for vVol on NetApp to the public.

I have some issues registering the VASA Provider (VP). Registration seemed OK but I couldn't see the VP GUI in the vSphere Web client.

Tried to reboot the 3 pieces of the infratructure to no avail.

Now if I want to unregister the VP I have the following error message.

Re: [BETA] Using VVOLs with NetApp & VMware

I can't seem to get the VASA provider registered either. Could it be because the VASA VP has an IPv6 address and I'm only setup for IPv4?

VSC Log:

[2014-07-07 15:10:56,846] [qtp826432820-24] [ERROR] NVPF-00014:  Unable to contact VASA server on host of

[2014-07-07 15:10:56,846] [qtp826432820-24] [DEBUG] Target method failed for RemoteInvocation: method name 'registerVasaProvider'; parameter types [java.lang.String, java.lang.String]

com.netapp.nvpf.api.model.ApiException: NVPF-00014:  Unable to contact VASA server on host of

          at com.netapp.nvpf.api.VasaRegistrationServiceImpl.processVPError(VasaRegistrationServiceImpl.java:143)

          at com.netapp.nvpf.api.VasaRegistrationServiceImpl.registerVasaProvider(VasaRegistrationServiceImpl.java:73)

          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

          at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

          at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

          at java.lang.reflect.Method.invoke(Unknown Source)

          at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:307)

          at org.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:182)

          at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:149)

          at org.springframework.remoting.support.RemoteInvocationTraceInterceptor.invoke(RemoteInvocationTraceInterceptor.java:77)

          at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:171)

          at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:204)

          at com.sun.proxy.$Proxy125.registerVasaProvider(Unknown Source)

          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

          at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

          at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

          at java.lang.reflect.Method.invoke(Unknown Source)

          at org.springframework.remoting.support.RemoteInvocation.invoke(RemoteInvocation.java:205)

          at org.springframework.remoting.support.DefaultRemoteInvocationExecutor.invoke(DefaultRemoteInvocationExecutor.java:38)

          at org.springframework.remoting.support.RemoteInvocationBasedExporter.invoke(RemoteInvocationBasedExporter.java:78)

          at org.springframework.remoting.support.RemoteInvocationBasedExporter.invokeAndCreateResult(RemoteInvocationBasedExporter.java:114)

          at org.springframework.remoting.httpinvoker.HttpInvokerServiceExporter.handleRequest(HttpInvokerServiceExporter.java:74)

          at com.netapp.nvpf.api.NvpfHttpInvokerServiceExporter.handleRequest(NvpfHttpInvokerServiceExporter.java:49)

          at org.springframework.web.context.support.HttpRequestHandlerServlet.service(HttpRequestHandlerServlet.java:65)

          at javax.servlet.http.HttpServlet.service(HttpServlet.java:848)

          at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:598)

          at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1367)

          at com.netapp.nvpf.container.vsphere.request.VSphereClientRequestContextFilter.doFilterInternal(VSphereClientRequestContextFilter.java:47)

          at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76)

          at org.springframework.web.filter.DelegatingFilterProxy.invokeDelegate(DelegatingFilterProxy.java:236)

          at org.springframework.web.filter.DelegatingFilterProxy.doFilter(DelegatingFilterProxy.java:167)

          at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1338)

          at org.springframework.web.filter.RequestContextFilter.doFilterInternal(RequestContextFilter.java:83)

          at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76)

          at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1338)

          at com.netapp.nvpf.container.util.GWTCacheFilter.doFilter(GWTCacheFilter.java:55)

          at org.springframework.web.filter.DelegatingFilterProxy.invokeDelegate(DelegatingFilterProxy.java:236)

          at org.springframework.web.filter.DelegatingFilterProxy.doFilter(DelegatingFilterProxy.java:167)

          at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1338)

          at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:484)

          at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:119)

          at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:486)

          at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:233)

          at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1065)

          at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:413)

          at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:192)

          at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:999)

          at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117)

          at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:250)

          at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:149)

          at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:111)

          at org.eclipse.jetty.server.Server.handle(Server.java:350)

          at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:454)

          at org.eclipse.jetty.server.BlockingHttpConnection.handleRequest(BlockingHttpConnection.java:47)

          at org.eclipse.jetty.server.AbstractHttpConnection.content(AbstractHttpConnection.java:900)

          at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.content(AbstractHttpConnection.java:954)

          at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:851)

          at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:235)

          at org.eclipse.jetty.server.BlockingHttpConnection.handle(BlockingHttpConnection.java:66)

          at org.eclipse.jetty.server.bio.SocketConnector$ConnectorEndPoint.run(SocketConnector.java:254)

          at org.eclipse.jetty.server.ssl.SslSocketConnector$SslConnectorEndPoint.run(SslSocketConnector.java:665)

          at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:603)

          at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:538)

          at java.lang.Thread.run(Unknown Source)

Re: [BETA] Using VVOLs with NetApp & VMware

I re-installed vCenter and VASA and now the plugin is registered. I'm now having issues with VASA not offering any SVMs when I try to create VVOL Datastore.

Re: [BETA] Using VVOLs with NetApp & VMware

Hi Guys

Just wanted to let you know I'm working to reproduce this, then we'll figure it out and get back to you.

Stay tuned!


Re: [BETA] Using VVOLs with NetApp & VMware

Will do

Sent from my iPhone

Re: [BETA] Using VVOLs with NetApp & VMware

I've found a couple of things also, and here are some workarounds to try.

If you're failing to register the VASA Provider within the VSC configuration menu:

1)  Check to insure all networking info is configured in the VP.  I ran into an issue where I didn't enter DNS settings and even though they were on the same local subnet and VSC & VP could ping each other, it was still failing to register.

2)  Try triggering a manual storage discovery in the storage controllers tab of VSC.  Wait a few mins and try again.

3)  On first boot, you have to have VMtools installed on the VP for it to finish installation (this is an obvious one, but sometimes overlooked).  Access the appliance console and it will walk you right through the steps nicely.

4)  Make sure you've rebooted after the VMtools installation finishes.


Re: [BETA] Using VVOLs with NetApp & VMware


i was getting this error while deploying VCENTER appliance ?

An error occurred while invoking external commands: 'ERROR: Return Value: 1, Stdout: , Stderr: Traceback (most recent call last): File "/bin/syshostname", line 72, in <module> raise ValueError("pnid %s specified is not valid" % pnid) ValueError: pnid pal.sap.corp specified is not valid '. my company domain is "pal.sap.corp" and i have specified this in global name ? did anyone got errror like this .

can you tell me what is the fix.



Re: [BETA] Using VVOLs with NetApp & VMware

I haven't seen that specific error, but it sounds like one of two things:

1.  DNS not correctly set up for the vCSA.  The IP address must match the hostname you give it, and hostname and FQDN must resolve correctly to that IP from the workstation where you manage it all.

2.  Parameters not entered correctly in the customize template screen when deploying the OVA. 

How did you deploy the OVA?  Using the new vSphere Host Client (which can directly deploy OVA/OVF to ESXi servers) or to a running instance of a previous version of vCenter?  Previous versions of vCenter don't understand the newer OVA format.  As a result, the customize template screen will ask for network information in two places, asking for slightly different things each time.  You have to provide the same values for equivalent parameters, with the exception of netmask.  In the upper section, it wants the number of bits (22 and 24 are common).  In the lower section, it wants the actual mask ( or are common).  And of course this all has to match the actual A record in the DNS server.

Reading the /bin/syshostname script, it looks like it wants FQDN and you passed just the domain name maybe in the Host Network Identity field in the first screenshot.

Re: [BETA] Using VVOLs with NetApp & VMware


I have right DNS and all networks can reach via DNS .

I was using Vsphere new client (Vmware Host Client ) whcih was inside the pacakge of Beta Vcenter ISO. I have installed this client and connected ESX6.0 beta server, upon logging in what i notice that we have to 2 options deploying OVF . 1) Deploy OVF template 2) Deploy Vcenter Server Appliance.

I was using the 2nd option becuase this is VCENTER and get the error that reported earlier, however if i use Deploy OVF by selecting Vcenter OVA it was completed but when you power on it fails with "installation fails".

Can you provide which option should be used, also i am working on to build a windows 2008 R2 so that i can install the package of vcenter instead of apliacne. Keep you posted , meanwhile please let me know if you have any idea how to overcome the above errors.



Re: [BETA] Using VVOLs with NetApp & VMware


Ok, i have found issue related to ESX beta VM Ware Client and fixed it .

Now the VCENTER appliance completed and i can logon wot VSPHERE client directly with VCENTER, however several probelms after logging .

1) i cannot add any data centers, esx server ? when i click Add Data Center the screen just running forever( bottom of the screen) and no output ?

same thing for other options. i cannot do anything without adding Data center or ESX server host ?

Did anyone come across this error?



Re: [BETA] Using VVOLs with NetApp & VMware

Make sure you log on as administrator@vsphere.local, not as root.

Sent from my phone. Any resemblance to an actual email is purely coincidental. Please keep head and arms inside vehicle at all times.

Re: [BETA] Using VVOLs with NetApp & VMware

Use deploy vcenter appliance.

Sent from my phone. Any resemblance to an actual email is purely coincidental. Please keep head and arms inside vehicle at all times.

Re: [BETA] Using VVOLs with NetApp & VMware


Thanks, but i wasn't able to logon with administrator@vsphere.local while i was doing vcenter appliance deployment phase,  i have specified this name "vsphere.local" as my hostname "hostname.pal.sap.corp"? should i use as "administrator@hostname.pal.sap.corp"?

can i see what username it was using in any configuration or installation file (i know this is appliance ..but we can get some history of deployment logs ?)



Re: [BETA] Using VVOLs with NetApp & VMware

yes, i did deployed only appliance.



Re: [BETA] Using VVOLs with NetApp & VMware

ok i found it from appliance log files that said with the following message, so i logged with user" Administrator@navolvc3.pal.sap.corp" and i was able to add all the things that were not working with user: root/.


Installation Complete

You can now login to vSphere web client from https://navolvc3.pal.sap.corp/vsphere-client as Administrator@navolvc3.pal.sap.corp".


thanks for the tip about user: Administrator.



Cloud Volumes ONTAP
Review Banner
All Community Forums