VMware Solutions Discussions

Can't use VSC 5.0


Hi all,

Just installed VSC 5.0 on Server 2008 R2 and registered (using IP addresses for Plugin & vSphere - not hostnames) to a VCSA running vSphere 5.5.

When I login to the VCSA using a member of the Administrator role, there is no sign of VSC from the home screen, or any of the Actions menus.  When logging in to the VCSA as administrator@vsphere.local, I can see that the plugin is enabled (Administration > Client Plug-Ins), there is no VSC Icon on the home screen, however there is the NetApp VSC option available from the Actions menu; the problem is, if I attempt to "Update Host and Storage Data" I get an error: "Unable to connect to Virtual Storage Console server.  Please make sure that the Virtual Storage Console sever is running".

I am certain this is a permissions problem, but for the life of me I can't figure out how to resolve it, from the VSC installation guide, I have downloaded the RBAC User Creator for Data OnTap, but I don't want to just start creating users & roles ad hoc.  I don't even want to use anything to do with RBAC (yet), I would be happy at this moment in time to just be able to login to vSphere as a member of the Adminstrator role, and have access t the VSC plugin.

Can anyone shed some light on where I am going wrong?!



Message was edited by: Colin Birchall - Reason: spelling mistakes




I encountered "Unable to connect to Virtual Storage Console server"albeit working on a lab environment (vSphere 5.5 with Windows 2008 R2 vCenter  and 7-Mode ONTAP 8.2.1 simulators).  Like you VSC was visible, reportedly sucessful registration and NetApp privileges installed into vCenter.

Mine's now sort of fixed - I'd created a specific user role for registering plugins with vCenter that only has the Extension: Register, Unregister and Manage privileges and used that to 'successfully' register VSC.  I went back and re-registered the VSC on the https://localhost:8143/Register.html  url (capital R!) using the root administrator@vsphere.local account and now VSC works (added controllers etc and optimised ESXi hosts)

The SSO admin is overkill and i need to go back and read the furnished material to confirm actual registration account requirements before I hit production. May be a starter that helps fix your issue.

Thx, that worked after I used the administrator account


woodrog instrauction did not esolve my issue of not having permissions, still getting the same error.


Has anyone else seen this issue?  I am experiencing the same, and the community suggested resolution has not worked.  VSC Console 5.0 vCenter 5.5 U1 Windows 2012R2



are you using the client agent to log into vcenter or are you using the web client?  You have to use the web client to log into vcenter.  VSC 5 only support the web client right now.


Yes.  Web Client only.  From the web client, the plugin shows up and I can see my controllers, yet as soon as I transition from Details to Entities while creating a backup job, I get an Error "Unable to connect to Virtual Storage Console server.  Please mae sure that the VIrtual Storage Console server is running"  I get this every time, even when logged in as the SSO admin so I am pretty sure it isnt a rights issue.  That said, I dont know WHAT the issue is so I suppose it could be rights related somewhere.




You need to check the logs.  off the top of my head it sounds like a DNS or RPC issue.  I noticed that you are using 2012 R2.  Is firewall turned on locally on that server?  Can you send me the output of the VSC log?


My advice is uninstall the VSC. Make sure that you login as a local administrator to the W2K8 box that you are doing the install on and turn UAC off. Right click run as administrator. There is a KB that documents issues with installs with UAC turned on. Do not attempt to use a domain admin account.  You can only access VSC 5.0 through the Web Client.  If you still have the issue I would look at the vsc.log as Castrojsec suggested.

This is windows 2012 R2 but I'll try the local admin install.


Run as administrator (domain admin) seems to have done the trick!  Thank you all!


Was able to resolve the same issue using woodrog's instructions. Thank you!

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner