VMware Solutions Discussions

Configuring routing between directly attached servers and NetApp

zinovik_igor

  Hello.

I need help in configuring routing between NetApp and a pair of two Dell PowerEdge 1950

both are running VmWare ESX 3.5.

My NetApp is a cluster pair of FAS 3020c both running DOT 7.3.2.

So i want to unload cisco 2960G switch by directly attaching esx servers to netapp filers.

Currently i have following setup:

fas1> ifconfig e0b

e0b: flags=0x2d48867<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500
        inet 192.168.1.11 netmask 0xfffffff0 broadcast 192.168.1.15
        ether 00:a0:98:09:8d:f7 (auto-1000t-fd-up) flowcontrol full

fas1> ifconfig e0d

e0d: flags=0x2d48867<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500
        inet 192.168.1.12 netmask 0xfffffff0 broadcast 192.168.1.15
        ether 00:a0:98:09:8d:f5 (auto-1000t-fd-up) flowcontrol full

fas1> route -s

Routing tables

Internet:
Destination      Gateway            Flags     Refs     Use  Interface
default          172.20.21.254      UGS         3     1264  vif0
127              localhost          UGS         0      216  lo
localhost        localhost          UH          3       17  lo
172.20.21/24     link#7             UC          0        0  vif0
fas1             2:a0:98:9:8d:f6    UHL         0      347  lo
172.20.21.254    0:1f:9e:d2:7e:0    UHL         1        0  vif0
172.20.21.255    ff:ff:ff:ff:ff:ff  UHL         0      702  vif0
192.168.1/28     link#4             UC          0        0  e0b
192.168.1.2      192.168.1.12       UGHS        0      279  e0b
192.168.1.11     0:a0:98:9:8d:f7    UHL         0       21  lo
192.168.1.12     0:a0:98:9:8d:f5    UHL         1        1  lo
192.168.1.15     ff:ff:ff:ff:ff:ff  UHL         0      100  e0b

So my problem is that when i try to add route in fas1 i do not know how to specify an NIC

where traffic should flow.  I have esx1 (192.168.1.1/28) sitting behind e0b (192.168.1.2/28)

and esx1 behind e0d.  How can i specify interface in route command ?  If i just add route via

route add 192.168.1.2.  It appears that traffic to esx2 flows through e0b NIC, but i want it to

flow through e0d.

I've attached a picture of what i try to implement.  Maybe i should just put second esx server

into separate C-class network?

1 REPLY 1

zinovik_igor

I solved my problem.  After reading about `metric' parameter in route command

i understanded how to solve the issue.


fas1> route add 192.168.1.2 192.168.1.12 0


fas1> route -s

Routing tables

Internet:
Destination      Gateway            Flags     Refs     Use  Interface
default          172.20.21.254      UGS         3     2721  vif0
127              localhost          UGS         0      492  lo
localhost        localhost          UH          3       21  lo
172.20.21/24     link#7             UC          0        0  vif0
fas1             2:a0:98:9:8d:f6    UHL         0      806  lo
172.20.21.254    0:1f:9e:d2:7e:0    UHL         1        0  vif0
172.20.21.255    ff:ff:ff:ff:ff:ff  UHL         0     1161  vif0
192.168.1/28     link#4             UC          0        0  e0b
192.168.1.1      0:50:56:74:36:51   UHL         7  3351536  e0b
192.168.1.2      0:50:56:70:d1:f2   UHLS        5        7  e0d
192.168.1.11     0:a0:98:9:8d:f7    UHL         0      939  lo
192.168.1.12     0:a0:98:9:8d:f5    UHL         0        1  lo
192.168.1.15     ff:ff:ff:ff:ff:ff  UHL         0     1018  e0b

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public