VMware Solutions Discussions

Fail to create or mount NFS Vvol Datastore using VP 6.0 and VSC 6.0


Hi, I have successfully setup a Netapp VASA 6.0 and VSC 6.0 to using my Netapp box running Cmod Ontap 8.3 envrionment.  Also successfully deploy and register the VASA and VSC with a Vcenter 6.0 (also have ESXi host 6.0).  But Everytime I tried to create a NFS Vvol Datastore from the Web Vsphere Client, I've got the following error message:


"Unkown error, Error: Unable to create datastore Cannot create or mount NFS datastore because none of your ESC host's VMkernel interfaces preferences file doesn't contain include any of the VMkernel interfaces on this host.  See the dfault allo.nfs.mount.networks property and its asscociated comment in that file for more details occurred on the server.  See VP server logs for more detail".


I know my VP,VSC vms and ESXi host locate on a different subnet than the Netapp Storage:


subnet mask of the VP ,VSC and ESXi host  is

subnet mask of Netapp storage is


So I have edited the two files on VSC machine:  C:\Program Files\NetApp\Virtual Storage Console\etc\kamino\kaminoprefs.xml and C:\Program Files\NetApp\Virtual Storage

Console\etc\caster\kaminosdkprefs.xml, to replace "ALL" with the ESXi host subnet mask  the follow to entries in the two files:


<entry key="default.allow.nfs.mount.networks" value=""/>




<entry key="default.allow.iscsi.mount.networks" value=""/>


But I still get the same error message as above.  Just wonder if anybody having this problem.  I am really appreciated any help from resolving this problem.