VMware Solutions Discussions

Failed to get Data ONTOP Version reporting by SnapDrive and VMWare Host Attach Kit - Ontap 7.3.1



     I've been having this problem for awhile with SnapDrive and the NetApp SIM, but I just recently tried to install the VMWare Host Attach Kit on a bunch of VMWare Servers and got substantially the same error message, so I think the problem might be related to 7.3.1

Basically, here is the error message reported by SnapDrive:

-------------------------  SnapDrive Operation Start ---------------------------------
Disk Create operation on server - WIN-DDIYQKN2UE4 failed for reason
Failed to get Data ONTAP version running on the storage system simtest.
Error Description: Can't connect to host (err=2).
--------------------- The complete operation list is shown as follows -------------------

********************* Server Name: WIN-DDIYQKN2UE4*********************

1. Checking input parameters
2. Checking policies
3. Turning off snap scheduling
4. Creating the LUN
5. Creating a partition
6. Formatting the disk with NTFS
7. Mounting volume on the disk
8. Failed to get Data ONTAP version running on the storage system simtest.  Error Description: Can't connect to host (err=2).   ...
------------------------------------------ Operation Done ---------------------------------------

The LUN Creates fine and show up in Windows, but it does not appear in SnapDrive -- I was trying to to an iSCSI LUN with this one.

I ran into substantially the same error message last week in a FibreChannel environment with the VMWare Host Attach Kit -- the prevailing similiarity seems to be both the Sim and the NetApp were running 7.3.1.

Has anyone seen this issue with 7.3.1 and SnapDrive or the VMWare Host Attach Kit?




This sounds like a problem with user rights, can you confirm that the SnapDrive Service account has admin rights on the storage controller?  Also, if you are running in a domain you should check that the controller can communicate with the domain properly and that DNS is working properly.

Mike Slisinger



On the Windows box, SnapDrive is an administrator on both the NetApp and the Windows Box, and on VMWare I'm using the NetApp's root account. DNS resolution works fine and there are no network problems.

I'm wondering if it has something to do with the fact that both the SnapDrive version and the ESX host attach kit were written before on Ontap 7.3.1 release ... I've seen similiar problem on Windows, where I try to run an app on 2003/Vista/2008 and get an error message saying I need Windows 2000, XP or above, because it's checking to see if the OS Version == a certian value, instead of >= a certain value.

Still, I've seen this twice now ... and got a few 'me too's' on my last thread -- I'm wondering if anyone is using SnapDrive/ESX Host Attach Kit against a 7.3.1 NetApp and not seeing this?




Ah yes... this one... I've been here before.

What is issue was, was that the virtual machine could not resolve the storage controller's hostname itself (e.g. nyfiler01). Not the DNS name, not the IP address; it must be able to resolve the hostname on its own even if the DNS name resolves & the IP address is reachable.

So put in a DNS search suffix in the NIC properties or an entry into the hosts file.

I was told that this is a .NET Framework issue...

Kind Regards,