VMware Solutions Discussions

Lost Password for SRA 4.0 - need to upgrade

We are vsphere 6.5 using SRM 6.5 with Netapp SRA 4.1

onTap is 9.1p17

 

Before we go to 9.3 and onwards I will need to get onto the VASA 7.x Documentation says that if your running SRA previous to 4.x you should deplay the VASA Appliance then migrate.  if you're running 4.0 onwards (which is us) we can simply do an in place upgrade.  The problem is that I inherited the environment and the default credentails of maint and a password of admin123 were changed. So I am unable to acess the shell or Web UI.

 

What is the impact of just removing the SRA within SRM, building a fresh instal of the VASA 71 and adding that back to SRM?

What kind of confgiuration will be lost? will it affect my snapmirrors that I have in place?

 

3 REPLIES 3

Re: Lost Password for SRA 4.0 - need to upgrade

Nothing?  Wow I guess I stumped the community...

Re: Lost Password for SRA 4.0 - need to upgrade

I know that you do not have the 'maint' password, but if you have the 'administrator' password you can navigate to https://sra-ip:9083 and then access the web based cli. From there you can run the commands 'cluster list' and 'vserver list' to access how you have your storage added, i.e. cluster IP addresss, admin user credentials, etc. Just make note of those specific details.

 

Once you have that information, you should just decomission the SRA 4.0P1 appliances and fresh deploy the 7.x appliances. Remember to also remove the SRA adapters from the SRM servers and then install the the 7.x SRA adapters. Be sure to also decommission any old instances of VSC 6.x in the environment as they will conflict with 7.x. If you are still using SMVI backups with VSC 6.x, reach out to your account team.

 

Once SRA 4.0P1 and VSC 6.x are removed from the environment, and VSC/SRA 7.x is deployed, you just need to add the storage back in the same manner as documented in your notes. If you add the storage in the same manner (cluster vs. vserver level) and use the same credentials, your existing SRM confugrations should not even need to be updated.

Re: Lost Password for SRA 4.0 - need to upgrade

Your snapmirrors will not be affected by this

Forums