VMware Solutions Discussions

ONTAP Tools for VMware vSphere: Upgrade successful but information no longer displays in vSphere.

DBWannaBe
459 Views

Hello,

 

I decided to upgrade my existing ONTAP Tools for VMware vSphere 9.8p2 install up to 9.10 and the installation completed successfully but now when I attempt to open the tool from the administrative menu, the "Overview" windows just displays "Loading..."  The same shows up when I click on "Storage Systems".  Neither of these windows display any information.  Other windows like "Storage Mapping" will pull up information after 10 seconds or so.  The two other windows mentioned will not display information even if I leave them for an hour or more.

 

I have restarted the ONTAP Tool appliance and that makes no difference.  I have also restarted the vCenter appliance.  I have also verified that the credentials being used are correct.

 

Another issue that is related is that when I right click on a server in my vSphere environment and go to "NetAPP ONTAP tools", I no longer get the full menu of items that I used to.  I only get an option to "Assign QoS".  If I click on that I get the message "Datastore details are currently being fetched from storage, refresh after discovery has been completed successfully."  I don't want to actually configure QoS at this point; it's the only menu option available so I clicked on it.

 

I performed this update a couple of days ago and the refresh discovery never completes.

 

I opened a support ticket with VMware but once they figured out that the plug-in deployed correctly, they told me that it wasn't their issue to fix and that I should speak with NetApp support. 🙂 

 

Does anyone have any suggestions?

3 REPLIES 3

Ontapforrum
409 Views

Is the ticket raised with NetApp ?  Any update. I am hoping OTV compatibility with ESXi/vcenter/Ontap is satisfied in the support matrix IMT. Also, after upgrading have you tried to re-establish/authenticate with connected NetApp Cluster/SVM?

 

I tried to look up for any possible bugs for this 9.10 version, just one comes up. But, it is related to Performance issue with SRA when more than 1 cluster is peered to source cluster. Fix is to go to 9.11.  

SU513: [Impact: High] ONTAP Tools for VMware vSphere (OTV) 9.8 can cause high CPU usage - NetApp Knowledge Base

DBWannaBe
358 Views

No, I have not yet raised a ticket with NetApp.  I was waiting to see if the forum had a simple answer.

 

I did check the compatibility table to verify that my systems were compatible with this update.  They are.  Weirdly, the newest version of ONTAP Tools (9.11) doesn't have any compatibilities listed which is why I went with 9.10.

 

I re-entered the NetApp password just to be sure, but there has been no change.  The tool sees the NetApp storage, as evidenced by the fact that I'm able to view storage in other tabs.

 

I didn't see any bugs related to this issue either.

 

Thanks for the reply.  I'll keep searching for an answer.

DBWannaBe
348 Views

Arghh!!  I cleared the cache on my browser and the problematic pages began displaying again.

 

I still have the issue where I right click on a guest and the only option that I have is QoS.  Normally a right click on a guest gives you a list of 10(?) items.

Public