VMware Solutions Discussions

Problem with VSC 2.0


I think we may have stumbled across a bug in the VSC 2.0.  When using the RCU to build a new machine, if we select our Server 2008 R2 template, and then choose our 2008 customization spec, it does not apply to the VM.  If we just deploy the VM from template using VMware and select the spec it does apply.  We do not have this issue with Server 2003. Has anyone else run into this, and can we confirm, is this a bug?





<Install directory>/etc/kamino/kaminoprefs.xml

View solution in original post



Hi Erick,

Are you using a "&", "<", or ">" symbol in any part of your customization spec?  If so, could you try removing it?


None of those symbols are present anywhere in the spec.  It is pretty standard.  There is other odd behavior too.  Even the BIOS settings I have in the template are no longer present when I run the RCU from the VSC for Windows Server 2008 R2.


Have you tried to clone the VM using normal vCenter cloning (and have it apply the customization specification)? Does that behave the same way?

Regarding the BIOS settings...

The .nvram file stores the BIOS settings. By default, the VSC does not clone the nvram file.

If you want the nvram file to be cloned (so that the clone VMs have the same BIOS settings as the template), then you can have it do so. Here's how:

Inside the VSC install directory (which is probably C:\Program Files\NetApp\Virtual Storage Console\etc\kamino), you'll find a file called preferences.xml

If you edit this file with wordpad, you'll find the following on line 12:

<entry key="default.create.copyNvramFile" value="false"/>

If you change this to:

<entry key="default.create.copyNvramFile" value="True"/>

The VSC should then clone the nvram file in all cloning tasks.

I'm not totally sure, but I think you might need to restart the "NetApp vSphere Plugin Framework" service for the change to take affect.




Cloning using VMware works as expected.  It copies all settings including the BIOS and properly applies the guest OS spec.  There are a lot of customizations that we make in the BIOS including removing the floppy drive and controller, shutting off the serial and parallel ports, and setting the boot order.  I don't understand why this would not be included by default.  Additionally I made the modifications to the xml file listed here, and it fails when it tries to copy the NVRAM file.


Hi Erick,

Thanks for chatting with us. Is there a support case for this? If you can give me the case number I can follow up on this. 




I haven't opened a case yet, but this is what happens with the NVRAM copy:

vSphere Status

File [NFS1]Windows-Server-2008-R2/Windows-Server-2008-R2.vmtx/Windows-Server-2008-R2.nvram was not found

The proper path to the NVRAM file is [NFS1]Windows-Server-2008-R2/Windows-Server-2008-R2.nvram


Case #2001703101


We have the same issue on VSC 2.0.1.  I couldn't find the .xml file to edit in the new version.  Any idea where it is located so I can have my cloning copy the NVRAM file?


<Install directory>/etc/kamino/kaminoprefs.xml

View solution in original post

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner