VMware Solutions Discussions

Restore entire VM with VSC 2.0.1 fails with nfs license error

stefan_pietsch
2,645 Views

Hi there,

we use vSphere ESXi 4.1 and VSC 2.0.1, Datastores are connected via FC.

Backups with VSC are successfull.

Now a colleague deleted a machine in vCenter and I wanted to restore the entire machine.

I select the backup, the machine and click on 'restore'. Then I select 'The entire virtual machine', select the host and click on 'restore'.

The job starts but fails after some seconds with an error message: "Storage system error: Api nfs-exportfs-list-rules requires license for nfs or flexcache_nfs".

We have no NFS license, but we don't use NFS in vSphere! It's all fibrechannel connected.

Does somebody have a hint for me?

Kind regards,

Stefan

1 ACCEPTED SOLUTION

sharmas
2,644 Views

The bug here http://now.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=465867 shows fixed. This was fixed in VSC 2.0.1P1.

https://now.netapp.com/NOW/download/software/vsc_win/2.0.1P1/

So it should automatically be rolled to VSC 2.1

View solution in original post

6 REPLIES 6

watan
2,644 Views

Hi Stefan,

This is a known issue and a public burt has been posted . http://now.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=465867

Workaround is to add the NFS license to the filer.  Reports notes that this should be fixed in the next release.

stefan_pietsch
2,644 Views

Thanks!

But how can I add the NFS license when we didn't buy it?

We bought the SnapManager VI License, though!

Has it been fixed in VSC 2.1?

Kind regards,

Stefan

watan
2,644 Views

I'm not part of the VSC team so not sure if this got rolled into 2.1 as its not listed in the burt fixes.  I'll see if I can find more info or get somebody from VSC to chime in.

sharmas
2,645 Views

The bug here http://now.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=465867 shows fixed. This was fixed in VSC 2.0.1P1.

https://now.netapp.com/NOW/download/software/vsc_win/2.0.1P1/

So it should automatically be rolled to VSC 2.1

watan
2,644 Views

Thanks Sharmas!

stefan_pietsch
2,644 Views

Hi Sharmas,

I updated to VSC 2.1 and the restore worked.

Thanks!

Kind regards,

Stefan

Public